aboutsummaryrefslogtreecommitdiffstats
path: root/main/lvm2
diff options
context:
space:
mode:
authorIlya Fedorushkov <illanfed@gmail.com>2019-04-08 13:53:40 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-30 11:34:39 +0000
commit6fcaa4e4f807873c4670b4be1b4300a4e2d7fe85 (patch)
tree81db77e1f0cfec95f8221fcf1d0d730180cf82b1 /main/lvm2
parent01fe80a36804b7d76682bb2ccf995aa79fa93081 (diff)
downloadaports-6fcaa4e4f807873c4670b4be1b4300a4e2d7fe85.tar.bz2
aports-6fcaa4e4f807873c4670b4be1b4300a4e2d7fe85.tar.xz
main/lvm2: update patches for actual version(2.02.182)
Diffstat (limited to 'main/lvm2')
-rw-r--r--main/lvm2/APKBUILD4
-rw-r--r--main/lvm2/fix-stdio-usage.patch22
-rw-r--r--main/lvm2/mlockall-default-config.patch12
3 files changed, 18 insertions, 20 deletions
diff --git a/main/lvm2/APKBUILD b/main/lvm2/APKBUILD
index 291b3f941e..1e738a61b3 100644
--- a/main/lvm2/APKBUILD
+++ b/main/lvm2/APKBUILD
@@ -124,10 +124,10 @@ extra() {
}
sha512sums="e241b151985ea66bda683fccc43542acb2bafeafae033b13c168c63a36e9a7a19f373031ff6654508fce2eb83e21e1d4171664504d4bbb2d00ce6c1dbdfe41a0 LVM2.2.02.182.tgz
-6ea4efad03f8632f2883f33f9d9f8ca295f7d8d2aa1bfbfa7738e7d711727a511758848dde5776b222bd74e6fb60bed8b56a3cd2f74ca448b8d86f50470a42b9 fix-stdio-usage.patch
+bb487ee287872d7e9650a5a187c64a8e18525dde876fd4c5fe71d80f2263345fd793eb52b65ebdc91178d0ca96ffff145fbaa049bcf513f63a8b0e0306141e22 fix-stdio-usage.patch
9272ec8c5184ef5dc776ead8f74132e072b7563b5119a3a38b712f00d92a1e3878c9b3a54eb2b01dcba038110c686b39d4c17ecd0eb258537e9217d7ed03c408 mallinfo.patch
33004594a5cce7af1e493a2a66ce8ad2f864dde3b2ec0960d0fda9df9b7bcf65d9455f9eccf7860f48726c48f14111b843b0a0c9bd395ef2952b41aaab8092b2 library_dir-default-config.patch
-d190c40a137b006d7b63298069c93ff08d2804b990e85d44739cd7c48beec9a569903b98f0d940895fc7365723ba886acd7ef0e08f1f65a1a391d1c448ce080e mlockall-default-config.patch
+e113c518bb7f03feea892252518f1df3733fad32f04ed0701a8313cf35ba932c3e2d29ecd97d739f8908b481ed1f6a2eb0129cb307214d0a084d9a8d0b4bc290 mlockall-default-config.patch
a853078660fd2fd943538924f56e81dc5793294e26b8f61d93e6188893f15f4a438d33792b341c1865d61e03f4a371b7c7ee0db5f4130ef7cb7aeaeb9290086a lvm.initd
07caf8fa942290f3c953cc2463aaf55bac01d0bcb9351daf3880fa4d0eefb67fe00761c46a7a4da91cd2f8e492a12fed35853a15dc939cd80d19d3303bc3951d lvm.confd
ca06220065525e93347efb7a5746a367cf55cb03574e50eed29bd7c4eae036bdd199b52c42d81811b6e742649e73ab8e66525f663bed66f9d1d82d0efde50332 dmeventd.initd"
diff --git a/main/lvm2/fix-stdio-usage.patch b/main/lvm2/fix-stdio-usage.patch
index 39ba2e1b4e..ea11b7137f 100644
--- a/main/lvm2/fix-stdio-usage.patch
+++ b/main/lvm2/fix-stdio-usage.patch
@@ -30,20 +30,20 @@
--- ./lib/commands/toolcontext.c.orig
+++ ./lib/commands/toolcontext.c
@@ -1860,7 +1860,7 @@
- /* FIXME Make this configurable? */
- reset_lvm_errno(1);
+ /* FIXME Make this configurable? */
+ reset_lvm_errno(1);
-#ifndef VALGRIND_POOL
+#if !defined(VALGRIND_POOL) && defined(__GLIBC__)
- /* Set in/out stream buffering before glibc */
- if (set_buffering) {
- /* Allocate 2 buffers */
-@@ -2241,7 +2241,7 @@
- if (cmd->libmem)
- dm_pool_destroy(cmd->libmem);
+ /* Set in/out stream buffering before glibc */
+ if (set_buffering
+ #ifdef SYS_gettid
+@@ -2254,7 +2254,7 @@
+ if (cmd->libmem)
+ dm_pool_destroy(cmd->libmem);
-#ifndef VALGRIND_POOL
+#if !defined(VALGRIND_POOL) && defined(__GLIBC__)
- if (cmd->linebuffer) {
- /* Reset stream buffering to defaults */
- if (is_valid_fd(STDIN_FILENO) &&
+ if (cmd->linebuffer) {
+ /* Reset stream buffering to defaults */
+ if (is_valid_fd(STDIN_FILENO) &&
diff --git a/main/lvm2/mlockall-default-config.patch b/main/lvm2/mlockall-default-config.patch
index 1daadeff3d..305ddeedb7 100644
--- a/main/lvm2/mlockall-default-config.patch
+++ b/main/lvm2/mlockall-default-config.patch
@@ -9,16 +9,14 @@
# Configuration option activation/monitoring.
# Monitor LVs that are activated.
-diff --git a/lib/config/defaults.h b/lib/config/defaults.h
-index 8ab1fde..57b2443 100644
---- a/lib/config/defaults.h
-+++ b/lib/config/defaults.h
-@@ -53,7 +53,7 @@
- #define DEFAULT_WAIT_FOR_LOCKS 1
+--- ./lib/config/defaults.h.orig
++++ ./lib/config/defaults.h
+@@ -55,7 +55,7 @@
#define DEFAULT_LVMLOCKD_LOCK_RETRIES 3
+ #define DEFAULT_LVMETAD_UPDATE_WAIT_TIME 10
#define DEFAULT_PRIORITISE_WRITE_LOCKS 1
-#define DEFAULT_USE_MLOCKALL 0
+#define DEFAULT_USE_MLOCKALL 1
#define DEFAULT_METADATA_READ_ONLY 0
#define DEFAULT_LVDISPLAY_SHOWS_FULL_DEVICE_PATH 0
-
+ #define DEFAULT_UNKNOWN_DEVICE_NAME "[unknown]"