aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxc/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-24 18:28:46 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-07-25 15:01:29 +0000
commit6dfaefa8eb2f9f68d26fda184ad8cfbc4c56f4b8 (patch)
tree83045f18cb60d92b71b61df5dcc0a47d4049e2c7 /main/lxc/APKBUILD
parent95fc6607a42e0e5d219afb2f28b9d4d3a21f176d (diff)
downloadaports-6dfaefa8eb2f9f68d26fda184ad8cfbc4c56f4b8.tar.bz2
aports-6dfaefa8eb2f9f68d26fda184ad8cfbc4c56f4b8.tar.xz
main/lxc: move download template to separate subpackage
Diffstat (limited to 'main/lxc/APKBUILD')
-rw-r--r--main/lxc/APKBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index bc617593e1..1690e5e10c 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -1,10 +1,11 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lxc
pkgver=2.0.3
_pkgver=${pkgver/_rc/.rc}
-pkgrel=2
+pkgrel=3
pkgdesc="Userspace interface for the Linux kernel containment features"
url="https://linuxcontainers.org/lxc/"
arch="all"
@@ -15,7 +16,7 @@ makedepends="$depends_dev lvm2 util-linux automake autoconf libtool lua5.2-dev
linux-headers bash tar docbook2x"
options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lvm lua5.2-lxc:_lua52
- $pkgname-templates $pkgname-libs"
+ $pkgname-download:_download $pkgname-templates $pkgname-libs"
source="https://github.com/lxc/lxc/archive/lxc-$_pkgver.tar.gz
version.patch
download-template-tmpfs.patch
@@ -24,6 +25,8 @@ source="https://github.com/lxc/lxc/archive/lxc-$_pkgver.tar.gz
"
builddir="$srcdir/lxc-lxc-$_pkgver"
+_tmpldir="usr/share/lxc/templates"
+
prepare() {
default_prepare || return 1
./autogen.sh
@@ -78,17 +81,25 @@ _lua52() {
done
}
+_download() {
+ pkgdesc="LXC container image downloader template"
+ arch="noarch"
+ depends="$pkgname gnupg tar xz"
+
+ mkdir -p "$subpkgdir"/$_tmpldir
+ mv "$pkgdir"/$_tmpldir/lxc-download "$subpkgdir"/$_tmpldir/
+}
+
templates() {
- local tmpldir="usr/share/lxc/templates"
- pkgdesc="Templates for LXC"
+ pkgdesc="Templates for LXC (except alpine and download)"
arch="noarch"
depends="bash tar"
- mkdir -p "$subpkgdir"/$tmpldir
- mv "$pkgdir"/$tmpldir/* "$subpkgdir"/$tmpldir/ || return 1
+ mkdir -p "$subpkgdir"/$_tmpldir
+ mv "$pkgdir"/$_tmpldir/* "$subpkgdir"/$_tmpldir/ || return 1
# Keep alpine template in the base package (doesn't need bash or GNU tar).
- mv "$subpkgdir"/$tmpldir/lxc-alpine "$pkgdir"/$tmpldir/
+ mv "$subpkgdir"/$_tmpldir/lxc-alpine "$pkgdir"/$_tmpldir/
}
dev() {