aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxc
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-11-13 00:40:34 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-11-26 01:17:35 +0100
commitf55cfeb9c139bce7dcde2d1ecae902d9e7019ada (patch)
tree7ce022752bf2e62f1a4613f8f7dfae5b1650b4e4 /main/lxc
parentc007638e76c166a283b5ac09ebfd6a284843c0d1 (diff)
downloadaports-f55cfeb9c139bce7dcde2d1ecae902d9e7019ada.tar.bz2
aports-f55cfeb9c139bce7dcde2d1ecae902d9e7019ada.tar.xz
main/lxc: update initd for 2.1 config
* use: lxc.uts.name & lxc.rootfs.path
Diffstat (limited to 'main/lxc')
-rw-r--r--main/lxc/APKBUILD4
-rw-r--r--main/lxc/lxc.initd6
2 files changed, 5 insertions, 5 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index a60c30ff49..f24c99660f 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -5,7 +5,7 @@
pkgname=lxc
pkgver=2.1.1
_pkgver=${pkgver/_rc/.rc}
-pkgrel=0
+pkgrel=1
pkgdesc="Userspace interface for the Linux kernel containment features"
url="https://linuxcontainers.org/lxc/"
arch="all"
@@ -149,6 +149,6 @@ EOF
sha512sums="205d30a8914013f3d31bdcae9786a13b6728ae0d3630f51c644f06e1e96d03631630569a0ce55764ff7b8ee1d1d4d723926fdb2b916396aea212d9c3040b45ab lxc-2.1.1.tar.gz
e2ffcbf55447291a8434a4f37255c3a6a119bc4116c75d205006aa2b070bf6be28535cf6107bead14bbf64bf9fa415346ab544bd1c15e1add7d1c6380e6b2def version.patch
-1037e0b773553aa04b619cec7cfc8fa504af830e58c8211eda367da7e36aeb88f45fca1f955a08fc4fa3f9da660017d5fe7145a326a2064cf15e24d1772d9e27 lxc.initd
+bd4cb27659cd1b18d97cfb1415f6d57bdbc23fb4504c17b90a51c44f1fac2a4acb1fb731d744fb5211b90fa5988cc9f0e3c257b8b115b9f8522120973bbfe399 lxc.initd
5b83b0323e58bf00bd1e124c265729499cee97559b6fe18482962e3bed50d121b4c7a09f25cbce7b1e18d4234627bc4b4581ba2060e33cd022f105b4429cef01 lxc.conf
02fd192d137cbb5b6db6959275387d05653f41dad5a5e46ae9b53cacead8cef937733927284658d3f0b910de81f9364c7f0248db990efd88806cf3029264c214 download-template-tmpfs.patch"
diff --git a/main/lxc/lxc.initd b/main/lxc/lxc.initd
index c43803e2ad..7d39817944 100644
--- a/main/lxc/lxc.initd
+++ b/main/lxc/lxc.initd
@@ -43,10 +43,10 @@ checkconfig() {
# no need to output anything, the function takes care of that.
[ -z "${CONFIGFILE}" ] && return 1
- utsname=$(lxc_get_var lxc.utsname)
+ utsname=$(lxc_get_var lxc.uts.name)
if [ "${CONTAINER}" != "${utsname}" ]; then
eerror "You should use the same name for the service and the"
- eerror "lxc.utsname. Right now the lxc.utsname is set to ${utsname}"
+ eerror "lxc.uts.name : Right now the lxc.uts.name is set to : ${utsname}"
return 1
fi
}
@@ -67,7 +67,7 @@ start() {
rm -f /var/log/lxc/${CONTAINER}.log
- rootpath=$(lxc_get_var lxc.rootfs)
+ rootpath=$(lxc_get_var lxc.rootfs.path)
# verify that container is not on tmpfs
dev=$(df -P "${rootpath}" | awk '{d=$1}; END {print d}')
type=$(awk -v dev="$dev" '$1 == dev {m=$3}; END {print m}' /proc/mounts)