aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-07-06 10:36:51 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-06 10:36:51 +0200
commit1a30a04c86dd7664de2630bb955103e40aac1111 (patch)
tree0063bf791c8f07ae0d6e1227684c80a5791e056b /main/lxc
parente471e6075c5fc51c7fb0634017f78b8b472a056b (diff)
downloadaports-1a30a04c86dd7664de2630bb955103e40aac1111.tar.bz2
aports-1a30a04c86dd7664de2630bb955103e40aac1111.tar.xz
main/lxc: backport ppc64le support
Diffstat (limited to 'main/lxc')
-rw-r--r--main/lxc/0001-lxc-alpine-Add-support-for-ppc64le.patch40
-rw-r--r--main/lxc/APKBUILD6
2 files changed, 44 insertions, 2 deletions
diff --git a/main/lxc/0001-lxc-alpine-Add-support-for-ppc64le.patch b/main/lxc/0001-lxc-alpine-Add-support-for-ppc64le.patch
new file mode 100644
index 0000000000..4f9210e1f0
--- /dev/null
+++ b/main/lxc/0001-lxc-alpine-Add-support-for-ppc64le.patch
@@ -0,0 +1,40 @@
+From 2933a5ce1c06724a5efceaee8b44ab197eb3b714 Mon Sep 17 00:00:00 2001
+From: Breno Leitao <breno.leitao@gmail.com>
+Date: Mon, 12 Jun 2017 13:45:52 -0500
+Subject: [PATCH] lxc-alpine: Add support for ppc64le
+
+Starting at version 3.6, Alpine Linux has support for ppc64le
+architecture. Adding the new keys also.
+
+Signed-off-by: Breno Leitao <breno.leitao@gmail.com>
+---
+ templates/lxc-alpine.in | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
+index 1547c2c1..9a9200f7 100644
+--- a/templates/lxc-alpine.in
++++ b/templates/lxc-alpine.in
+@@ -43,7 +43,10 @@ readonly APK_KEYS_SHA256="\
+ 2adcf7ce224f476330b5360ca5edb92fd0bf91c92d83292ed028d7c4e26333ab alpine-devel@lists.alpinelinux.org-4d07755e.rsa.pub
+ ebf31683b56410ecc4c00acd9f6e2839e237a3b62b5ae7ef686705c7ba0396a9 alpine-devel@lists.alpinelinux.org-5243ef4b.rsa.pub
+ 1bb2a846c0ea4ca9d0e7862f970863857fc33c32f5506098c636a62a726a847b alpine-devel@lists.alpinelinux.org-524d27bb.rsa.pub
+-12f899e55a7691225603d6fb3324940fc51cd7f133e7ead788663c2b7eecb00c alpine-devel@lists.alpinelinux.org-5261cecb.rsa.pub"
++12f899e55a7691225603d6fb3324940fc51cd7f133e7ead788663c2b7eecb00c alpine-devel@lists.alpinelinux.org-5261cecb.rsa.pub
++73867d92083f2f8ab899a26ccda7ef63dfaa0032a938620eda605558958a8041 alpine-devel@lists.alpinelinux.org-58199dcc.rsa.pub
++9a4cd858d9710963848e6d5f555325dc199d1c952b01cf6e64da2c15deedbd97 alpine-devel@lists.alpinelinux.org-58cbb476.rsa.pub
++780b3ed41786772cbc7b68136546fa3f897f28a23b30c72dde6225319c44cfff alpine-devel@lists.alpinelinux.org-58e4f17d.rsa.pub"
+
+ readonly APK_KEYS_URI='http://alpinelinux.org/keys'
+ readonly DEFAULT_MIRROR_URL='http://dl-cdn.alpinelinux.org/alpine'
+@@ -126,6 +129,7 @@ parse_arch() {
+ aarch64 | arm64) echo 'aarch64';;
+ armv7) echo 'armv7';;
+ arm*) echo 'armhf';;
++ ppc64le) echo 'ppc64le';;
+ *) return 1;;
+ esac
+ }
+--
+2.13.2
+
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 0c1bbbf7c6..e6fe028c43 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -5,7 +5,7 @@
pkgname=lxc
pkgver=2.0.8
_pkgver=${pkgver/_rc/.rc}
-pkgrel=0
+pkgrel=1
pkgdesc="Userspace interface for the Linux kernel containment features"
url="https://linuxcontainers.org/lxc/"
arch="all"
@@ -25,6 +25,7 @@ source="https://github.com/lxc/lxc/archive/lxc-$_pkgver.tar.gz
download-template-tmpfs.patch
alpine-default-repos.patch
+ 0001-lxc-alpine-Add-support-for-ppc64le.patch
"
builddir="$srcdir/lxc-lxc-$_pkgver"
@@ -151,4 +152,5 @@ e2ffcbf55447291a8434a4f37255c3a6a119bc4116c75d205006aa2b070bf6be28535cf6107bead1
1037e0b773553aa04b619cec7cfc8fa504af830e58c8211eda367da7e36aeb88f45fca1f955a08fc4fa3f9da660017d5fe7145a326a2064cf15e24d1772d9e27 lxc.initd
5b83b0323e58bf00bd1e124c265729499cee97559b6fe18482962e3bed50d121b4c7a09f25cbce7b1e18d4234627bc4b4581ba2060e33cd022f105b4429cef01 lxc.conf
b3b8c47a8594cefff58cef74efe9e6bf0dd8422a40289c4398ea34e61d04dd3d95c567e880a4b123df42ffac3fae179b63b130b357eb6659f73f922f2908d971 download-template-tmpfs.patch
-a8ce110414578ba58cee8c15762f59d5185d7e543e8fdd46e1e7148895600b3603499e2c2b9222ee36d867b07e8c9776d8dee994a1647bac4d1fb478129faaf9 alpine-default-repos.patch"
+a8ce110414578ba58cee8c15762f59d5185d7e543e8fdd46e1e7148895600b3603499e2c2b9222ee36d867b07e8c9776d8dee994a1647bac4d1fb478129faaf9 alpine-default-repos.patch
+16e6fb35827f05b0aae48264f9f32dc8e7295348a5f44719f72a70e8b18ca5070b52fa9a407b7aab9dba73e48ba5d0a6afbbc0dc4b175bf4ada699ad9946dc6f 0001-lxc-alpine-Add-support-for-ppc64le.patch"