aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxdm/execinfo.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-20 12:30:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-20 12:52:14 +0000
commit37b233b77504d5105c8c3b015103f8d26d226276 (patch)
tree8c098db1fd6b805407c35b69f26ef6b1c7e9793d /main/lxdm/execinfo.patch
parent698054208746279e9d4be2200a239c1432a453ae (diff)
downloadaports-37b233b77504d5105c8c3b015103f8d26d226276.tar.bz2
aports-37b233b77504d5105c8c3b015103f8d26d226276.tar.xz
main/lxdm: build fix for musl
Diffstat (limited to 'main/lxdm/execinfo.patch')
-rw-r--r--main/lxdm/execinfo.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/main/lxdm/execinfo.patch b/main/lxdm/execinfo.patch
new file mode 100644
index 0000000000..2adab16198
--- /dev/null
+++ b/main/lxdm/execinfo.patch
@@ -0,0 +1,49 @@
+diff -auNr lxdm-0.4.1.orig//configure.ac lxdm-0.4.1/configure.ac
+--- lxdm-0.4.1.orig//configure.ac 2011-11-16 22:27:33.624019150 +0100
++++ lxdm-0.4.1/configure.ac 2011-11-16 22:29:49.537310486 +0100
+@@ -23,7 +23,7 @@
+
+ # Checks for header files.
+ AC_PATH_X
+-AC_CHECK_HEADERS([shadow.h stdlib.h string.h unistd.h utmpx.h])
++AC_CHECK_HEADERS([shadow.h stdlib.h string.h unistd.h utmpx.h, execinfo.h])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_TYPE_PID_T
+diff -auNr lxdm-0.4.1.orig//src/lxdm.c lxdm-0.4.1/src/lxdm.c
+--- lxdm-0.4.1.orig//src/lxdm.c 2011-11-16 22:27:33.617019240 +0100
++++ lxdm-0.4.1/src/lxdm.c 2011-11-16 22:29:19.030694008 +0100
+@@ -52,7 +52,9 @@
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+
++#ifdef HAVE_EXECINFO_H
+ #include <execinfo.h>
++#endif
+
+ #ifdef HAVE_UTMPX_H
+ #include <utmpx.h>
+@@ -1576,6 +1578,7 @@
+ return success;;
+ }
+
++#ifdef HAVE_EXECINFO_H
+ static void log_sigsegv(void)
+ {
+ void *array[40];
+@@ -1591,12 +1594,15 @@
+
+ free(bt_strs);
+ }
++#endif
+
+ static void sigsegv_handler(int sig)
+ {
+ switch(sig){
+ case SIGSEGV:
++#ifdef HAVE_EXECINFO_H
+ log_sigsegv();
++#endif
+ lxdm_quit_self(0);
+ break;
+ default: