aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxterminal
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-10-04 16:37:39 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-11-12 07:26:22 +0000
commit31d7be985845ca15592e3a88182e7420df7c46ac (patch)
treed7050a1e2368646fe005a313d4a71dbbb7e321ca /main/lxterminal
parent013a2fc6e4b0df6e8f28bccac7804b3e62a765cc (diff)
downloadaports-31d7be985845ca15592e3a88182e7420df7c46ac.tar.bz2
aports-31d7be985845ca15592e3a88182e7420df7c46ac.tar.xz
main/lxterminal: upgrade to 0.3.2
Diffstat (limited to 'main/lxterminal')
-rw-r--r--main/lxterminal/APKBUILD12
-rw-r--r--main/lxterminal/CVE-2016-10369.patch26
2 files changed, 5 insertions, 33 deletions
diff --git a/main/lxterminal/APKBUILD b/main/lxterminal/APKBUILD
index 660528c961..2b605cc41e 100644
--- a/main/lxterminal/APKBUILD
+++ b/main/lxterminal/APKBUILD
@@ -1,17 +1,16 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lxterminal
-pkgver=0.3.0
-pkgrel=2
+pkgver=0.3.2
+pkgrel=0
pkgdesc="Desktop-independent VTE-based terminal emulator"
-url="http://lxde.org/"
+url="https://lxde.org/"
arch="all"
license="GPL-2.0-or-later"
depends=""
makedepends="vte-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.xz
- CVE-2016-10369.patch"
+source="https://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
# secfixes:
@@ -41,5 +40,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="05eb6ef8904de9e34a4046ded67d3cece5a93a5b19d37d423f3bde67051a2f0a0e3195443669709a8b732d27246852353a2c9ba59026f9d71f8df6bb1152e37f lxterminal-0.3.0.tar.xz
-e9fc3d612a8a59e4fb7cd5c339759a7450c8829caa3645e9c859e603a450a173a9215670598d696dc8830de1c78b4a62959bfdb166962cd869ae5a9ec8bab33d CVE-2016-10369.patch"
+sha512sums="0711d6eeed1f7e301fd24e0d5f750a48f29cc10c7cd40bcc1de57cceddfe4cb15718e9fb812da975faff24aed99cdd3978cb5f29838f47e276fce47f01577119 lxterminal-0.3.2.tar.xz"
diff --git a/main/lxterminal/CVE-2016-10369.patch b/main/lxterminal/CVE-2016-10369.patch
deleted file mode 100644
index 170ad884be..0000000000
--- a/main/lxterminal/CVE-2016-10369.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From f99163c6ff8b2f57c5f37b1ce5d62cf7450d4648 Mon Sep 17 00:00:00 2001
-From: Yao Wei <mwei@lxde.org>
-Date: Mon, 8 May 2017 00:47:55 +0800
-Subject: [PATCH] fix: use g_get_user_runtime_dir for socket directory
-
-This bug is pointed out by stackexchange user that putting socket file in
-/tmp is a potential risk. Putting the socket dir in user directory could
-mitigate the risk.
----
- src/unixsocket.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/unixsocket.c b/src/unixsocket.c
-index 4c660ac..f88284c 100644
---- a/src/unixsocket.c
-+++ b/src/unixsocket.c
-@@ -140,7 +140,8 @@ gboolean lxterminal_socket_initialize(LXTermWindow * lxtermwin, gint argc, gchar
- * This function returns TRUE if this process should keep running and FALSE if it should exit. */
-
- /* Formulate the path for the Unix domain socket. */
-- gchar * socket_path = g_strdup_printf("/tmp/.lxterminal-socket%s-%s", gdk_display_get_name(gdk_display_get_default()), g_get_user_name());
-+ gchar * socket_path = g_strdup_printf("%s/.lxterminal-socket-%s", g_get_user_runtime_dir(), gdk_display_get_name(gdk_display_get_default()));
-+ printf("%s\n", socket_path);
-
- /* Create socket. */
- int fd = socket(PF_UNIX, SOCK_STREAM, 0);