aboutsummaryrefslogtreecommitdiffstats
path: root/main/mailx/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-10-13 08:13:09 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-10-13 08:13:09 +0000
commit785d6b68c3f5f048977fc361fe591085480fa5f4 (patch)
treea8bc930f989425094ee0081a515e0f8486022d1f /main/mailx/APKBUILD
parent877687e793a2758c4e6dbcbcc392ef7ab55e863a (diff)
downloadaports-785d6b68c3f5f048977fc361fe591085480fa5f4.tar.bz2
aports-785d6b68c3f5f048977fc361fe591085480fa5f4.tar.xz
main/mailx: move to main
Diffstat (limited to 'main/mailx/APKBUILD')
-rw-r--r--main/mailx/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/main/mailx/APKBUILD b/main/mailx/APKBUILD
new file mode 100644
index 0000000000..f656301b6e
--- /dev/null
+++ b/main/mailx/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=mailx
+pkgver=8.1.1
+pkgrel=0
+pkgdesc="A commandline utility for sending email"
+url="http://www.opengroup.org/onlinepubs/007908799/xcu/mailx.html"
+arch="all"
+license="BSD"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://ftp.archlinux.org/other/mailx/$pkgname-$pkgver-fixed.tar.gz
+ mailx-8.1.1.patch
+ mailx-gcc4.patch"
+
+_builddir="$srcdir/$pkgname-$pkgver-fixed"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i 's#/man/#/share/man/#' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="63cad526ac64b57bcba2c0daaa1f3048 mailx-8.1.1-fixed.tar.gz
+d66b9f419c5d215271ed434f5d780843 mailx-8.1.1.patch
+8716c7c7b3f5d348443230e2fe543bf6 mailx-gcc4.patch"