aboutsummaryrefslogtreecommitdiffstats
path: root/main/make/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2009-07-27 06:39:43 +0000
committerLeonardo Arena <rnalrd@gmail.com>2009-07-27 06:39:43 +0000
commitc66164b230fc33d7a903bbd1da6f803c2cadd0e2 (patch)
tree5b2c145554a597182448ac64167be76fd904d392 /main/make/APKBUILD
parentaad5f530b5a45159e9420d654173345006bde998 (diff)
parentdb7bf56b641e8ebb35d6f24ca8bca0b3b9e45c19 (diff)
downloadaports-c66164b230fc33d7a903bbd1da6f803c2cadd0e2.tar.bz2
aports-c66164b230fc33d7a903bbd1da6f803c2cadd0e2.tar.xz
Merge branch 'master' of git://dev.alpinelinux.org/aports
Diffstat (limited to 'main/make/APKBUILD')
-rw-r--r--main/make/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/main/make/APKBUILD b/main/make/APKBUILD
new file mode 100644
index 0000000000..5d2141402d
--- /dev/null
+++ b/main/make/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=make
+pkgver=3.81
+pkgrel=1
+pkgdesc="GNU make utility to maintain groups of programs"
+url="http://www.gnu.org/software/make"
+license=GPL
+depends=uclibc
+subpackages="$pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums='a4e9494ac6dc3f6b0c5ff75c5d52abba make-3.81.tar.gz'