aboutsummaryrefslogtreecommitdiffstats
path: root/main/mate-backgrounds
diff options
context:
space:
mode:
authorAlan Lacerda <alacerda@alpinelinux.org>2015-03-24 14:29:27 +0000
committerAlan Lacerda <alacerda@alpinelinux.org>2015-03-24 16:19:36 +0000
commitf2104197f5c22890a7b1e788e7d4aff94b4fba97 (patch)
tree91c1f0ee6f12236e2558cc50adcafcbc57f758c5 /main/mate-backgrounds
parent89bf33d69eaed7b9082213489091daddd228b3b6 (diff)
downloadaports-f2104197f5c22890a7b1e788e7d4aff94b4fba97.tar.bz2
aports-f2104197f5c22890a7b1e788e7d4aff94b4fba97.tar.xz
main/mate-backgrounds: move from testing
Diffstat (limited to 'main/mate-backgrounds')
-rw-r--r--main/mate-backgrounds/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/mate-backgrounds/APKBUILD b/main/mate-backgrounds/APKBUILD
new file mode 100644
index 0000000000..6536cee870
--- /dev/null
+++ b/main/mate-backgrounds/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-backgrounds
+pkgver=1.9.90
+pkgrel=0
+pkgdesc="Background images and data for MATE"
+url="https://github.com/mate-desktop/mate-backgrounds"
+arch="noarch"
+license="GPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev intltool"
+install=""
+subpackages=""
+source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="699fdfedde63cbe7f4a0928e6e9ec2cc mate-backgrounds-1.9.90.tar.xz"
+sha256sums="f9728de1b67dfac709841ed9dfc1f9bd2ef111761825b76df61d4cefd3d1779e mate-backgrounds-1.9.90.tar.xz"
+sha512sums="8b11d6ac026d8dcacd50a446405367ecf93f5408055fb7a79cbd1736005640e865b7e22e1812e0d628b4e34742dc128467f946fa56c396c6edd44652850ae058 mate-backgrounds-1.9.90.tar.xz"