aboutsummaryrefslogtreecommitdiffstats
path: root/main/mate-common
diff options
context:
space:
mode:
authorAlan Lacerda <alacerda@alpinelinux.org>2015-03-24 14:30:46 +0000
committerAlan Lacerda <alacerda@alpinelinux.org>2015-03-24 16:19:36 +0000
commit121253c5d1eb3b2ba6d0b33d498c46c5d0fd5530 (patch)
tree3d9c7ee6479569e8faf7e21de064c02aae36dea8 /main/mate-common
parent5cf52a49e9083c4312326bb38daab71df5991b33 (diff)
downloadaports-121253c5d1eb3b2ba6d0b33d498c46c5d0fd5530.tar.bz2
aports-121253c5d1eb3b2ba6d0b33d498c46c5d0fd5530.tar.xz
main/mate-common: move from testing
Diffstat (limited to 'main/mate-common')
-rw-r--r--main/mate-common/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/main/mate-common/APKBUILD b/main/mate-common/APKBUILD
new file mode 100644
index 0000000000..997995536b
--- /dev/null
+++ b/main/mate-common/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-common
+pkgver=1.9.90
+pkgrel=0
+pkgdesc="Common scripts and macros"
+url="http://mate-desktop.org/"
+arch="noarch"
+license="GPLv3+"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages=""
+source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="a0c4ddae3036778ec5bf373cec873928 mate-common-1.9.90.tar.xz"
+sha256sums="5f0ea27b306d8d58a043a3838a7145f180b4358ea8d5d29c04a71a07c774cc33 mate-common-1.9.90.tar.xz"
+sha512sums="9689a27e1a6ad29f4c8783195e9d1afc985bb5f381617242cc72211d5445243bfd1c2bef135dfe4d581d3dbc7152f9648e726d38123f51c971346cfbfb48d908 mate-common-1.9.90.tar.xz"