aboutsummaryrefslogtreecommitdiffstats
path: root/main/mbedtls/programs.makefile.patch
diff options
context:
space:
mode:
authorŁukasz Jendrysik <scadu@yandex.com>2015-03-19 13:00:32 +0100
committerŁukasz Jendrysik <scadu@yandex.com>2015-03-19 13:04:23 +0100
commit3a49adfaacb3217928700ba8737ab74be9a1ab6c (patch)
tree110c67ec313df1f158c2e9aad753c1c132d49c43 /main/mbedtls/programs.makefile.patch
parentfba418bcbac68007164daf6f681e67d765885adf (diff)
downloadaports-3a49adfaacb3217928700ba8737ab74be9a1ab6c.tar.bz2
aports-3a49adfaacb3217928700ba8737ab74be9a1ab6c.tar.xz
main/polarssl: rebrand to mbedtls, upgrade to 1.3.10
Diffstat (limited to 'main/mbedtls/programs.makefile.patch')
-rw-r--r--main/mbedtls/programs.makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/mbedtls/programs.makefile.patch b/main/mbedtls/programs.makefile.patch
new file mode 100644
index 0000000000..421f39cfcb
--- /dev/null
+++ b/main/mbedtls/programs.makefile.patch
@@ -0,0 +1,22 @@
+--- programs/Makefile 2014-07-31 12:20:17.748459143 -0400
++++ programs/Makefile 2014-07-31 12:21:35.388454356 -0400
+@@ -43,7 +43,7 @@
+ test/selftest test/ssl_test \
+ util/pem2der util/strerror \
+ x509/cert_app x509/crl_app \
+- x509/cert_req
++ x509/cert_req x509/cert_write
+
+ ifdef OPENSSL
+ APPS += test/o_p_test
+@@ -241,6 +241,10 @@
+ echo " CC x509/cert_req.c"
+ $(CC) $(CFLAGS) $(OFLAGS) x509/cert_req.c $(LDFLAGS) -o $@
+
++x509/cert_write: x509/cert_write.c ../library/libpolarssl.a
++ echo " CC x509/cert_write.c"
++ $(CC) $(CFLAGS) $(OFLAGS) x509/cert_write.c $(LDFLAGS) -o $@
++
+ clean:
+ ifndef WINDOWS
+ rm -f $(APPS)