aboutsummaryrefslogtreecommitdiffstats
path: root/main/mbedtls1/programs.makefile.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-31 08:45:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-31 08:46:38 +0000
commit99882bbebdf30f44c250518caa39d828dff96045 (patch)
treebc65116409a537420002044dc09d9c0688e4b579 /main/mbedtls1/programs.makefile.patch
parent0affe33dcd2b871de43750519c7304b8b84a56c0 (diff)
downloadaports-99882bbebdf30f44c250518caa39d828dff96045.tar.bz2
aports-99882bbebdf30f44c250518caa39d828dff96045.tar.xz
main/mbedtls1: renamed
rename for mbedtls-2.0 upgrade
Diffstat (limited to 'main/mbedtls1/programs.makefile.patch')
-rw-r--r--main/mbedtls1/programs.makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/mbedtls1/programs.makefile.patch b/main/mbedtls1/programs.makefile.patch
new file mode 100644
index 0000000000..3aef5f57c5
--- /dev/null
+++ b/main/mbedtls1/programs.makefile.patch
@@ -0,0 +1,22 @@
+--- programs/Makefile 2014-07-31 12:20:17.748459143 -0400
++++ programs/Makefile 2014-07-31 12:21:35.388454356 -0400
+@@ -43,7 +43,7 @@
+ test/selftest$(EXEXT) test/ssl_test$(EXEXT) \
+ util/pem2der$(EXEXT) util/strerror$(EXEXT) \
+ x509/cert_app$(EXEXT) x509/crl_app$(EXEXT) \
+- x509/cert_req$(EXEXT)
++ x509/cert_req$(EXEXT) x509/cert_write$(EXEXT)
+
+ ifdef OPENSSL
+ APPS += test/o_p_test
+@@ -241,6 +241,10 @@
+ echo " CC x509/cert_req.c"
+ $(CC) $(CFLAGS) $(OFLAGS) x509/cert_req.c $(LDFLAGS) -o $@
+
++x509/cert_write$(EXEXT): x509/cert_write.c ../library/libmbedtls.a
++ echo " CC x509/cert_write.c"
++ $(CC) $(LOCAL_CFLAGS) $(CFLAGS) x509/cert_write.c $(LOCAL_LDFLAGS) $(LDFLAGS) -o $@
++
+ clean:
+ ifndef WINDOWS
+ rm -f $(APPS)