aboutsummaryrefslogtreecommitdiffstats
path: root/main/mesa
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-11-20 21:41:07 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-11-20 21:51:08 +0000
commit32f331505e6e2ada549f3b62a584a7d185f3039d (patch)
tree245c5b3f203b7081bcc3655e571fdc284b933c1b /main/mesa
parentbfcd4f4ae56014b9d3fe6e80e1df399a80139be8 (diff)
downloadaports-32f331505e6e2ada549f3b62a584a7d185f3039d.tar.bz2
aports-32f331505e6e2ada549f3b62a584a7d185f3039d.tar.xz
main/mesa: fix bad if-macro on ppc64le
A backported commit causes a build failure on ppc64le. ``` /lp_bld_misc.cpp ../src/gallium/auxiliary/gallivm/lp_bld_misc.cpp:708:28: error: #if with no expression 708 | #if PIPE_ARCH_LITTLE_ENDIAN ``` Upstream issue: https://gitlab.freedesktop.org/mesa/mesa/issues/2131
Diffstat (limited to 'main/mesa')
-rw-r--r--main/mesa/APKBUILD4
-rw-r--r--main/mesa/mesa-fix-gallium-ifdef.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index fbfca5dbc0..eaf740b06c 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -59,6 +59,7 @@ source="
adjust-cache-deflate-buffer.patch
musl-fix-includes.patch
add-use-elf-tls.patch
+ mesa-fix-gallium-ifdef.patch
"
replaces="mesa-dricore"
@@ -320,4 +321,5 @@ _vulkan() {
sha512sums="881735c4fec07fb6557d01c2d5bb7971e2d4b2bedbb52fd1025dfb0222f8b1cbca080b6f849efe19ff514da8e6310fc6f0cde5b59fcc1c6a10e593876bcd6a38 mesa-19.2.5.tar.xz
cdf22d2da3328e116c379264886bd01fd3ad5cc45fe03dc6fd97bdc4794502598ee195c0b9d975fa264d6ac31c6fa108c0535c91800ecf4fcabfd308e53074cc adjust-cache-deflate-buffer.patch
cf849044d6cc7d2af4ff015208fb09d70bf9660538699797da21bda2ecb7c1892d312af83d05116afd826708d9caafb1d05a13f09139c558aea6fee931e3eee7 musl-fix-includes.patch
-6793388662ed98ae2a6bd964573d9ae380195f078386f0402957a1c9ac61b691b48a82ed41045c7172533f25b44f249af10f17f7ac68c8e03847594962cd4b04 add-use-elf-tls.patch"
+6793388662ed98ae2a6bd964573d9ae380195f078386f0402957a1c9ac61b691b48a82ed41045c7172533f25b44f249af10f17f7ac68c8e03847594962cd4b04 add-use-elf-tls.patch
+262398cc66e51093815052b0213065aeaabaf5851623b297e3565f8d672e0a578ab16962efd119d1e69e628c9f230c46f53bdbc1d5df7c5dd116eca0a90449d2 mesa-fix-gallium-ifdef.patch"
diff --git a/main/mesa/mesa-fix-gallium-ifdef.patch b/main/mesa/mesa-fix-gallium-ifdef.patch
new file mode 100644
index 0000000000..bda06345f5
--- /dev/null
+++ b/main/mesa/mesa-fix-gallium-ifdef.patch
@@ -0,0 +1,13 @@
+diff --git a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp.new
+index 1a47bab7e4..e05c906499 100644
+--- a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
++++ b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp.new
+@@ -705,7 +705,7 @@ lp_build_create_jit_compiler_for_module(LLVMExecutionEngineRef *OutJIT,
+ */
+ builder.setCodeModel(CodeModel::Large);
+
+-#if PIPE_ARCH_LITTLE_ENDIAN
++#ifdef PIPE_ARCH_LITTLE_ENDIAN
+ /*
+ * Versions of LLVM prior to 4.0 lacked a table entry for "POWER8NVL",
+ * resulting in (big-endian) "generic" being returned on