aboutsummaryrefslogtreecommitdiffstats
path: root/main/mkinitfs
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-01-21 21:44:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-21 21:46:59 +0000
commit8fdd5e2aa1dc66c6afa6413d66ec0c7a99ae0ad6 (patch)
treed54a521149c2b29647befb1577fbca1a73401d33 /main/mkinitfs
parent15dd032b51e05924cc658f482047351ccedad385 (diff)
downloadaports-8fdd5e2aa1dc66c6afa6413d66ec0c7a99ae0ad6.tar.bz2
aports-8fdd5e2aa1dc66c6afa6413d66ec0c7a99ae0ad6.tar.xz
main/mkinitfs: add hid-apple for apple keyboard support
fixes #9889
Diffstat (limited to 'main/mkinitfs')
-rw-r--r--main/mkinitfs/0001-features-add-support-for-hid-apple-keyboards.patch24
-rw-r--r--main/mkinitfs/APKBUILD9
2 files changed, 30 insertions, 3 deletions
diff --git a/main/mkinitfs/0001-features-add-support-for-hid-apple-keyboards.patch b/main/mkinitfs/0001-features-add-support-for-hid-apple-keyboards.patch
new file mode 100644
index 0000000000..bab77ed49e
--- /dev/null
+++ b/main/mkinitfs/0001-features-add-support-for-hid-apple-keyboards.patch
@@ -0,0 +1,24 @@
+From cb044ba7dae8dac17040303063e1ea7b0137f1a4 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 21 Jan 2019 21:40:54 +0000
+Subject: [PATCH] features: add support for hid-apple keyboards
+
+https://bugs.alpinelinux.org/issues/9889
+---
+ features.d/usb.modules | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/features.d/usb.modules b/features.d/usb.modules
+index 30b68e2..d29a9da 100644
+--- a/features.d/usb.modules
++++ b/features.d/usb.modules
+@@ -3,5 +3,6 @@ kernel/drivers/usb/storage
+ kernel/drivers/hid/usbhid
+ kernel/drivers/hid/hid-generic.ko
+ kernel/drivers/hid/hid-cherry.ko
++kernel/drivers/hid/hid-apple.ko
+ kernel/fs/fat
+ kernel/fs/nls
+--
+2.20.1
+
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index dab56d977a..6cf9cd970a 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mkinitfs
pkgver=3.4.0_rc1
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to generate initramfs images for Alpine"
url="https://git.alpinelinux.org/cgit/mkinitfs"
arch="all"
@@ -16,7 +16,9 @@ depends="busybox>=1.28.2-r1 apk-tools>=2.9.1 lddtree>=1.25"
subpackages="$pkgname-doc"
install="$pkgname.pre-upgrade $pkgname.post-install $pkgname.post-upgrade"
triggers="$pkgname.trigger=/usr/share/kernel/*"
-source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_ver.tar.xz"
+source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_ver.tar.xz
+ 0001-features-add-support-for-hid-apple-keyboards.patch
+ "
builddir="$srcdir/$pkgname-$_ver"
@@ -30,4 +32,5 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha512sums="c3ccf36411ecd30213bd3d9dd58ba70bff3ddf7e7a4f818d9f9bb5cc6d632c04b67982a458ae13d08033a69574c106277b557c9b9aeccf285d53425657978cc9 mkinitfs-3.4.0_rc1.tar.xz"
+sha512sums="c3ccf36411ecd30213bd3d9dd58ba70bff3ddf7e7a4f818d9f9bb5cc6d632c04b67982a458ae13d08033a69574c106277b557c9b9aeccf285d53425657978cc9 mkinitfs-3.4.0_rc1.tar.xz
+14b7655c92d6cd17de3011a532c5194b52cc926c5da40756b54ef6fae6e62216f24996236518d9f2407d39425f22066f550bf4efd4ef5741c236d15230cc567e 0001-features-add-support-for-hid-apple-keyboards.patch"