aboutsummaryrefslogtreecommitdiffstats
path: root/main/motif/03-no-demos.patch
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2014-11-09 12:34:22 -0800
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-11 08:04:31 +0100
commit882b99e9a7e4725d560c06f84469664aec7fe933 (patch)
tree2240ae9252238ac53b17a4a7545fc6a6854229be /main/motif/03-no-demos.patch
parenta7cd27edd7761a375740ed7fc1d8619c13049d68 (diff)
downloadaports-882b99e9a7e4725d560c06f84469664aec7fe933.tar.bz2
aports-882b99e9a7e4725d560c06f84469664aec7fe933.tar.xz
main/motif: move from testing
Diffstat (limited to 'main/motif/03-no-demos.patch')
-rw-r--r--main/motif/03-no-demos.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/main/motif/03-no-demos.patch b/main/motif/03-no-demos.patch
new file mode 100644
index 0000000000..03953c4f8f
--- /dev/null
+++ b/main/motif/03-no-demos.patch
@@ -0,0 +1,53 @@
+Description: Add option to disable building of demos
+Forwarded: http://bugs.motifzone.net/show_bug.cgi?id=1575
+Author: Graham Inggs <graham@nerve.org.za>
+Last-Update: 2013-01-09
+--- a/configure.ac
++++ b/configure.ac
+@@ -311,7 +311,20 @@
+ doc/man/man5/Makefile \
+ tools/Makefile \
+ tools/wml/Makefile \
+-demos/Makefile \
++lib/Xm/xmstring.list \
++])
++
++AC_ARG_ENABLE(demos, [ --disable-demos
++ Disable building demos])
++
++if test x$enable_demos = x
++then
++ enable_demos="yes"
++fi
++
++if test "$enable_demos" = "yes"
++then
++ AC_CONFIG_FILES([demos/Makefile
+ demos/lib/Makefile \
+ demos/lib/Xmd/Makefile \
+ demos/lib/Wsm/Makefile \
+@@ -395,6 +408,11 @@
+ demos/doc/programGuide/ch17/Makefile \
+ demos/doc/programGuide/ch17/simple_drop/Makefile \
+ demos/doc/programGuide/ch17/simple_drag/Makefile \
+-lib/Xm/xmstring.list \
+-])
++ ])
++ MAYBE_DEMOS=demos
++else
++ MAYBE_DEMOS=
++fi
++AC_SUBST(MAYBE_DEMOS)
++
+ AC_OUTPUT
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -29,6 +29,7 @@
+ tools \
+ clients \
+ doc \
+- demos
++ $(MAYBE_DEMOS)
++
+ AUTOMAKE_OPTIONS = 1.4
+ ACLOCAL_AMFLAGS = -I .