aboutsummaryrefslogtreecommitdiffstats
path: root/main/motif/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-29 15:44:55 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-29 21:10:41 +0000
commit78651dab7e64c4fff4000a9ebf34b69fae81d5fa (patch)
treec353907b048349e0a7a8f4d89448f1a68b3e0237 /main/motif/APKBUILD
parent254dbc9f0b4813396b262586a4481541756853a1 (diff)
downloadaports-78651dab7e64c4fff4000a9ebf34b69fae81d5fa.tar.bz2
aports-78651dab7e64c4fff4000a9ebf34b69fae81d5fa.tar.xz
main/motif: upgrade to 2.3.8
Diffstat (limited to 'main/motif/APKBUILD')
-rw-r--r--main/motif/APKBUILD70
1 files changed, 36 insertions, 34 deletions
diff --git a/main/motif/APKBUILD b/main/motif/APKBUILD
index 54bf3e7439..3785428cc9 100644
--- a/main/motif/APKBUILD
+++ b/main/motif/APKBUILD
@@ -1,45 +1,49 @@
# Contributor: Isaac Dunham <ibid.ag@gmail.com>
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=motif
-pkgver=2.3.4
-pkgrel=2
+pkgver=2.3.8
+pkgrel=0
pkgdesc="The Motif library"
-url="http://motif.ics.com/"
+url="https://motif.ics.com/"
arch="all"
options="!check" # Tests are interactive and require X11.
license="LGPL-2.1-or-later"
-depends=""
depends_dev="libx11-dev libxft-dev libxt-dev libxpm-dev libxext-dev xbitmaps"
-makedepends="$depends_dev libtool autoconf automake flex flex-libs flex-dev bison"
-install=""
+makedepends="$depends_dev automake autoconf libtool flex flex-libs flex-dev bison"
subpackages="mwm $pkgname-dev $pkgname-doc"
-source="https://downloads.sourceforge.net/$pkgname/Motif%20$pkgver%20Source%20Code/motif-$pkgver-src.tgz
-01-fix-autoconf.patch
-02-fix-format-security.patch
-03-no-demos.patch
-06-cast-size_t-to-int.patch
-07-fix_lintian_reported_manpage_typos.patch
-08-fix_hyphen_in_man_pages.patch
-09-fix_typo_in_libxm.patch
-10-fix_manpage-has-bad-whatis-entry.patch
-11-fix_underlinking.patch
-12-fix_buffer_overrun_in_libxm.patch
-13-fix_hardcoded_x11rgb_path.patch
-14-fix_ac_find_xft.patch
-15-link_uil_against_libuil.patch
-16-fix-undefined-use-of-sprintf.patch
-17-switch-to-system-iswspace.patch
-18-updated-fix-1565.patch"
+source="
+ https://downloads.sourceforge.net/project/motif/Motif%20$pkgver%20Source%20Code/motif-$pkgver.tar.gz
+ 02-fix-format-security.patch
+ 03-no-demos.patch
+ 06-cast-size_t-to-int.patch
+ 07-fix_lintian_reported_manpage_typos.patch
+ 08-fix_hyphen_in_man_pages.patch
+ 09-fix_typo_in_libxm.patch
+ 10-fix_manpage-has-bad-whatis-entry.patch
+ 11-fix_underlinking.patch
+ 13-fix_hardcoded_x11rgb_path.patch
+ 15-link_uil_against_libuil.patch
+ 16-fix-undefined-use-of-sprintf.patch
+ 17-switch-to-system-iswspace.patch
+ "
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ touch NEWS AUTHORS
+ autoreconf -fi
+}
build() {
# reasons for --disable- flags:
-#png, jpeg: most programs that use png and jpeg use the libraries directly;
+# png, jpeg: most programs that use png and jpeg use the libraries directly;
# enabling these mainly matters if you want to point the resources at a
# png/jpeg image.
-#printing: this is Xprint support; only CDE uses this, others print directly.
-#demos: one of the demos can break the build
+# printing: this is Xprint support; only CDE uses this, others print directly.
+# demos: one of the demos can break the build
cd "$builddir"
- ./autogen.sh \
+ export LDFLAGS="$LDFLAGS -lX11"
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--disable-demos \
@@ -50,7 +54,8 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static
make
}
@@ -60,6 +65,7 @@ package() {
}
mwm() {
+ pkgdesc="Motif Window Manager"
mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib/X11
mv "$pkgdir"/usr/bin/mwm "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/xmbind "$subpkgdir"/usr/bin
@@ -68,8 +74,7 @@ mwm() {
}
-sha512sums="fb1033caa68f25b93282fa6700d5b7856be217b3651072d86e7c93a747df5b31219230998eb93deae22a8fa698e816b1a30e52b3ae88ae1c01c1f0aac59a2af2 motif-2.3.4-src.tgz
-6ca24c74233552a4ce3ebb72f17ed277a3feca10bfa50c4680ed1eff917a11bf1f0bd39bcfdaaef1104466065c25c70251ba450f884bca637bc935565d0cdd9d 01-fix-autoconf.patch
+sha512sums="1ab8e8eece25ef97e948592b5fa3e19d98e932695290a18b7a8e90f1aa2766bc4f082bdbc3999dff5660e684821178a149040f76bb477163e53ca06474d02b55 motif-2.3.8.tar.gz
aff5be25bd25666e6134bc18faaffd54914cc390ca4d89a498efae5aa6dd175ac2b17dc719f7b8d27cff5db2f17b714ddfd5a163f219cad5f5c949cf5eb4786d 02-fix-format-security.patch
a54e0bbf95b7af1a2ba3a6031b3d4f36b6516d4b30d97804158c20b7cccda5df9628ed9a3c84ddda7cbd7779781ad065b0a16d39115184eff9fa509f6ec75ec6 03-no-demos.patch
605f3cc868c179c74ada49bd4ed40a39364f5d883866c99a9e8ffdb1c559e5e06ebf92a776b6a10df516b7f82a186b0084e55a9be1076498f5b742ca9376febc 06-cast-size_t-to-int.patch
@@ -78,10 +83,7 @@ fc955d88cc5c64655ec642786449968e2241c92653fec00bcf8a722d2c206a2ebad16e42529d4ba1
9157f68bf111b081811e08e43b0b67f31364230fd480381668750e130e264867697d3fc461d2011117ee267ebf3801c39d04b24d4c213433ac4a213b6ad8683a 09-fix_typo_in_libxm.patch
8081bddd444423cfe34995cef6c52eebf98d98616f34e9f9eae6240cfbfe8269cab2bdfbac7f85be85371a6f7375452471b32082d4a2dd0cffee242afe115c2f 10-fix_manpage-has-bad-whatis-entry.patch
18c155c13a21df3c95e94d15a8f31def6f40257baadc2ec9e29eef3e10197343824adeef54b75863cd9de25b5f46c4dc88e1e1f991f75c59048fc483a1ea1b43 11-fix_underlinking.patch
-666d0e0fe1ac9b63942224b4f49711e2590a99409fbf8893570f9b87b6e4f8f80e14c780fd2c4cdd664c6f130ee929b89bb20e189338c73dc7daf2750aa0c382 12-fix_buffer_overrun_in_libxm.patch
21dd0ba7fd9ed234d5115ad24547961592dd35c3d4843856800a564ff380482af0c5a35e3ce60d3258e4e9a47cb537435b4f08f460064e130d4327a4955b9975 13-fix_hardcoded_x11rgb_path.patch
-fcb28b3527821c6f4dce0aa86e864f21bf7261ed8a88766858b6f5d4a9ad7affcf94e49c586ae0e87a324a92404fea5965bff2959b2482035e49983d07b5ea45 14-fix_ac_find_xft.patch
8a726e253fa6ed8d14914fd2e2eb0bce8f240051a5fefc04ff56899f908a26300ad3292507b71c1ce65f57e7889e4067e35d0ab4ce15123bffccb606dfd9067f 15-link_uil_against_libuil.patch
2230f0af607111d014b0a648b807df18676a4a1421f10978c59a0a29b02dda38060163619bc54fda19a5186315f98fc8597b2ef6eb8ab7bedb6bd6972a77b38d 16-fix-undefined-use-of-sprintf.patch
-0cb0fa3a02a452f067649e02e855d6d3d728e4904bad009aebda9250de0c9fb76d352b6d9a857fcd1f920c5dfc6183f9b12886505c5570164fe92e99e97eea15 17-switch-to-system-iswspace.patch
-15cbb37beebf4b06b65a09612a05e4a5b2eaab09d23860332c90aec02cf8a59e0d351dce831eb98a774cb98d15c2ecf695669e5b5e6d0dcce77ce6b2658a8a84 18-updated-fix-1565.patch"
+0cb0fa3a02a452f067649e02e855d6d3d728e4904bad009aebda9250de0c9fb76d352b6d9a857fcd1f920c5dfc6183f9b12886505c5570164fe92e99e97eea15 17-switch-to-system-iswspace.patch"