aboutsummaryrefslogtreecommitdiffstats
path: root/main/motif/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 20:55:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 00:04:11 -0300
commita292b3188c984322f7c637a47becee8992e5b890 (patch)
treea04955cceb3f28f600b02d4fbb938ffd0e46872e /main/motif/APKBUILD
parentc139106d007b240615bf90f5a66fb7556a918a99 (diff)
downloadaports-a292b3188c984322f7c637a47becee8992e5b890.tar.bz2
aports-a292b3188c984322f7c637a47becee8992e5b890.tar.xz
community/motif: move from main
Diffstat (limited to 'main/motif/APKBUILD')
-rw-r--r--main/motif/APKBUILD89
1 files changed, 0 insertions, 89 deletions
diff --git a/main/motif/APKBUILD b/main/motif/APKBUILD
deleted file mode 100644
index bad9827f28..0000000000
--- a/main/motif/APKBUILD
+++ /dev/null
@@ -1,89 +0,0 @@
-# Contributor: Isaac Dunham <ibid.ag@gmail.com>
-# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
-pkgname=motif
-pkgver=2.3.8
-pkgrel=0
-pkgdesc="The Motif library"
-url="https://motif.ics.com/"
-arch="all"
-options="!check" # No testsuite
-license="LGPL-2.1-or-later"
-depends_dev="libx11-dev libxft-dev libxt-dev libxpm-dev libxext-dev xbitmaps"
-makedepends="$depends_dev automake autoconf libtool flex flex-libs flex-dev bison"
-subpackages="mwm $pkgname-dev $pkgname-doc"
-source="
- https://downloads.sourceforge.net/project/motif/Motif%20$pkgver%20Source%20Code/motif-$pkgver.tar.gz
- 02-fix-format-security.patch
- 03-no-demos.patch
- 06-cast-size_t-to-int.patch
- 07-fix_lintian_reported_manpage_typos.patch
- 08-fix_hyphen_in_man_pages.patch
- 09-fix_typo_in_libxm.patch
- 10-fix_manpage-has-bad-whatis-entry.patch
- 11-fix_underlinking.patch
- 13-fix_hardcoded_x11rgb_path.patch
- 15-link_uil_against_libuil.patch
- 16-fix-undefined-use-of-sprintf.patch
- 17-switch-to-system-iswspace.patch
- "
-
-prepare() {
- cd "$builddir"
- default_prepare
- touch NEWS AUTHORS
- autoreconf -fi
-}
-
-build() {
-# reasons for --disable- flags:
-# png, jpeg: most programs that use png and jpeg use the libraries directly;
-# enabling these mainly matters if you want to point the resources at a
-# png/jpeg image.
-# printing: this is Xprint support; only CDE uses this, others print directly.
-# demos: one of the demos can break the build
- cd "$builddir"
- export LDFLAGS="$LDFLAGS -lX11"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --disable-demos \
- --disable-printing \
- --disable-jpeg \
- --disable-png \
- --enable-xft \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --disable-static
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-mwm() {
- pkgdesc="Motif Window Manager"
- mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib/X11
- mv "$pkgdir"/usr/bin/mwm "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/xmbind "$subpkgdir"/usr/bin
- sed -e 's/\(xterm\)/xfce4-terminal||mrxvt||urxvt||st||\1/g' \
- "$pkgdir"/usr/lib/X11/system.mwmrc > "$subpkgdir"/usr/lib/X11/system.mwmrc
-}
-
-
-sha512sums="1ab8e8eece25ef97e948592b5fa3e19d98e932695290a18b7a8e90f1aa2766bc4f082bdbc3999dff5660e684821178a149040f76bb477163e53ca06474d02b55 motif-2.3.8.tar.gz
-aff5be25bd25666e6134bc18faaffd54914cc390ca4d89a498efae5aa6dd175ac2b17dc719f7b8d27cff5db2f17b714ddfd5a163f219cad5f5c949cf5eb4786d 02-fix-format-security.patch
-a54e0bbf95b7af1a2ba3a6031b3d4f36b6516d4b30d97804158c20b7cccda5df9628ed9a3c84ddda7cbd7779781ad065b0a16d39115184eff9fa509f6ec75ec6 03-no-demos.patch
-605f3cc868c179c74ada49bd4ed40a39364f5d883866c99a9e8ffdb1c559e5e06ebf92a776b6a10df516b7f82a186b0084e55a9be1076498f5b742ca9376febc 06-cast-size_t-to-int.patch
-0c4f678e34a00e3281337b06dffbf5f50d345f66b86bb86dd1532d435ce1630443f8ec6245bb773143783d1b5e6e99da5f1e68bd7391e23ee0a10e4fb99ed737 07-fix_lintian_reported_manpage_typos.patch
-fc955d88cc5c64655ec642786449968e2241c92653fec00bcf8a722d2c206a2ebad16e42529d4ba1905d40e4239e567189b7abd1b9f1c2bdad944cb134094b7c 08-fix_hyphen_in_man_pages.patch
-9157f68bf111b081811e08e43b0b67f31364230fd480381668750e130e264867697d3fc461d2011117ee267ebf3801c39d04b24d4c213433ac4a213b6ad8683a 09-fix_typo_in_libxm.patch
-8081bddd444423cfe34995cef6c52eebf98d98616f34e9f9eae6240cfbfe8269cab2bdfbac7f85be85371a6f7375452471b32082d4a2dd0cffee242afe115c2f 10-fix_manpage-has-bad-whatis-entry.patch
-18c155c13a21df3c95e94d15a8f31def6f40257baadc2ec9e29eef3e10197343824adeef54b75863cd9de25b5f46c4dc88e1e1f991f75c59048fc483a1ea1b43 11-fix_underlinking.patch
-21dd0ba7fd9ed234d5115ad24547961592dd35c3d4843856800a564ff380482af0c5a35e3ce60d3258e4e9a47cb537435b4f08f460064e130d4327a4955b9975 13-fix_hardcoded_x11rgb_path.patch
-8a726e253fa6ed8d14914fd2e2eb0bce8f240051a5fefc04ff56899f908a26300ad3292507b71c1ce65f57e7889e4067e35d0ab4ce15123bffccb606dfd9067f 15-link_uil_against_libuil.patch
-2230f0af607111d014b0a648b807df18676a4a1421f10978c59a0a29b02dda38060163619bc54fda19a5186315f98fc8597b2ef6eb8ab7bedb6bd6972a77b38d 16-fix-undefined-use-of-sprintf.patch
-0cb0fa3a02a452f067649e02e855d6d3d728e4904bad009aebda9250de0c9fb76d352b6d9a857fcd1f920c5dfc6183f9b12886505c5570164fe92e99e97eea15 17-switch-to-system-iswspace.patch"