aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-12-12 11:07:45 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-12-12 11:08:23 +0200
commit9be3c06726e81ee7ca393d2232bdb1f04070b40d (patch)
treecdc6f31b80d81d2bbb6a6ab3025a83aa7e09359b /main/musl/APKBUILD
parent25967063659719b2c6979fb5fb774382873d2dba (diff)
downloadaports-9be3c06726e81ee7ca393d2232bdb1f04070b40d.tar.bz2
aports-9be3c06726e81ee7ca393d2232bdb1f04070b40d.tar.xz
Revert "main/musl: use upstream getopt_long"
This reverts commit 21d10d3c2c3687b1475a4616ec9f341e3931f05b. This is broken still, and was pushed by accident.
Diffstat (limited to 'main/musl/APKBUILD')
-rw-r--r--main/musl/APKBUILD26
1 files changed, 9 insertions, 17 deletions
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index d5a86a7eba..d1001181e3 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.5
-pkgrel=3
+pkgrel=4
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -31,15 +31,12 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
0016-don-t-fail-posix_spawn-on-failed-close.patch
0017-use-direct-syscall-rather-than-write-function-in-pos.patch
0018-don-t-shadow-functions-with-macros-in-C.patch
- 0019-support-options-after-non-option-arguments-in-getopt.patch
- 0020-support-abbreviated-options-in-getopt_long.patch
- 0021-fix-getopt-handling-of-initial-in-optstring.patch
- 0022-accept-null-longopts-pointer-in-getopt_long.patch
1001-add-basic-dns-record-parsing-functions.patch
1002-implement-FNM_CASEFOLD-gnu-extension.patch
1003-remove-ulimit-fiddling-from-setxid.patch
ldconfig
+ getopt_long.c
__stack_chk_fail_local.c
getconf.c
getent.c
@@ -55,6 +52,10 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+
+ # use GNU compatible getopt() from BSD
+ rm -f src/misc/getopt*.c
+ cp "$srcdir"/getopt_long.c src/misc/
}
install_sysroot_headers() {
@@ -154,14 +155,11 @@ d9b4d921348fa86e57c44bf4c95714bd 0012-fix-uninitialized-output-from-sched_getaf
346d4db3e125b0679a4e5fedcbd99644 0016-don-t-fail-posix_spawn-on-failed-close.patch
b3e9f774ca938dcd1833dbe4af44fea8 0017-use-direct-syscall-rather-than-write-function-in-pos.patch
c59cc913f8ce2daffe4ceecc136ff81d 0018-don-t-shadow-functions-with-macros-in-C.patch
-d73e635f22a12a66d9c49c49b29ddfff 0019-support-options-after-non-option-arguments-in-getopt.patch
-15f097770f55d7a501dacc92deb8510d 0020-support-abbreviated-options-in-getopt_long.patch
-159a4a48e4e772050b7ed3f08f95954a 0021-fix-getopt-handling-of-initial-in-optstring.patch
-7d03bbaec20dd9c8faa3bef613a93da7 0022-accept-null-longopts-pointer-in-getopt_long.patch
2371eb1ce057fcb709a0e6a81f0d356c 1001-add-basic-dns-record-parsing-functions.patch
c4c2f5b48af0aef958d191659b9e5192 1002-implement-FNM_CASEFOLD-gnu-extension.patch
71b2a4dcc39c436a6b89173943424043 1003-remove-ulimit-fiddling-from-setxid.patch
830d01f7821b978df770b06db3790921 ldconfig
+61c6c1e84ed1df82abbe6d75e90cf21c getopt_long.c
0df687757221bbb0fc1aa67f1bd646f9 __stack_chk_fail_local.c
57ef2c63b9ec6a2041694ace97d4ffa2 getconf.c
2b941c4251cac44988a4abfc50e21267 getent.c
@@ -185,14 +183,11 @@ fa2306adeda1a2ee733fcbc64fc8e0bb377b3c0dd6870ea15322722f08d135e1 0014-add-arm-p
598856ea334962a36b3ff99d1909306deb7dfe235b0ab8c5e20e531027fe4cf4 0016-don-t-fail-posix_spawn-on-failed-close.patch
0f7a2a055c87c2a2616b106fcf5d9f35c8a710c12383e652744f7429e0bfae96 0017-use-direct-syscall-rather-than-write-function-in-pos.patch
da4d97570b552e332859f66c1a6fe8f4dee66b809e1e9f39fb1a3fc5a6e3574d 0018-don-t-shadow-functions-with-macros-in-C.patch
-ea6a42962f7c4d1155f4d0b96fa3368a4724713da6baaaea5425a1e4f14926dd 0019-support-options-after-non-option-arguments-in-getopt.patch
-2906e9f7bcdc52f8aa2799ce8a8058ac9a603e5a73185f16c616d736d8ac06b2 0020-support-abbreviated-options-in-getopt_long.patch
-d5810bc44bcad4c71aa734ce8ee03101496efb95af2037d0701b849906cc297d 0021-fix-getopt-handling-of-initial-in-optstring.patch
-e17e05b8818fef9cbe65f7e7a2e15e0db1aae61067599ae7c9a50b889e7adedd 0022-accept-null-longopts-pointer-in-getopt_long.patch
75053a31f6b84a64846d92c0ec631c76d7f747a9c0dc92a6dc1aa1bddfe2ea76 1001-add-basic-dns-record-parsing-functions.patch
57cb534a603dce32efa48be04ce7b1ca3f287fd8cc72258589fd529e86c1dd47 1002-implement-FNM_CASEFOLD-gnu-extension.patch
fb542c2bd5081ff2f601c519edb3dac8f54ca5c888f44bc6cfb84e6565472025 1003-remove-ulimit-fiddling-from-setxid.patch
b4a2c06db38742e8c42c3c9838b285a7d8cdac6c091ff3df5ff9a15f1e41b9c7 ldconfig
+d9b644ec20bc33e81a7c52b9fcf7973d835923a69faf50f03db45534b811bd96 getopt_long.c
299a7d75a09de3e2e11e7fb4acc3182e4a14e868093d2f30938fce9bfcff13da __stack_chk_fail_local.c
d87d0cbb3690ae2c5d8cc218349fd8278b93855dd625deaf7ae50e320aad247c getconf.c
68373a55e89ce85c562d941ccf588337d6cc6c9c17689d695f65cd7607134bbe getent.c
@@ -216,14 +211,11 @@ fcd04e66c812d108712d2ad937f117500d73311a0d1390bd6834d2093d844751bb0644f8b4ea820a
54a747fb14b38ffdd0abcd6b202a01e3e778cf853152a4554f7941a2e2544ab1c4c498e2646f421b421180e934ff0ff3372bbd8e08b59b800378cfb2db179940 0016-don-t-fail-posix_spawn-on-failed-close.patch
59060226956ddef64ade61b98a46a6faa5896061186abfa5a8adf1786584beff79acfa6197e2dc7ee1104ad300eda979ad18b6d5466a5dc98ae8957576a5b09d 0017-use-direct-syscall-rather-than-write-function-in-pos.patch
a627055d150087fae4d484c60ac7be8cccae0c1b8ddb88684d7b03255c72c1306dc55b7a1ee08ef691691a6b79bfd335609ea5271363c9f4824e48043dd5b037 0018-don-t-shadow-functions-with-macros-in-C.patch
-4ff213f1e54def3adb75a8817f5cc6708055b1a557d253493903629fb02750d66666137358eafe30cc8a1f81812379ffe838fe102c02c7b04dead52c77a7e95a 0019-support-options-after-non-option-arguments-in-getopt.patch
-36ce03cc336ed2b38d61489ccd65683e3a8d761a1aa155727e9c87e5f7a9c74ee7be0399778a6235cae7aff76c42d34f5005ad066eb5b7ca5859ed8397b910fe 0020-support-abbreviated-options-in-getopt_long.patch
-3f721c8aa7d49cc4c51f9bb33ee5efcabc75e702fc1e7fd7aacabb7b26a7548429983903ed2ddba679b29802fe3a205f9f63c2f5cfeb5d930f2d9ef2beb482f3 0021-fix-getopt-handling-of-initial-in-optstring.patch
-bebc872ae1797c3d38dd2ae4d1ea44bfbb351d820d9e69dde4a8d6165e52014e31e39c4c3bea2c17bb018a4f84165be149330efb1a82095c3affd13232dfd7ae 0022-accept-null-longopts-pointer-in-getopt_long.patch
5b8ffa0a50419581adbf6ce2dae5797774022551c6331fa5aa2ff13635eb72b74eedd8a92cb478d45d73e1956af2f588669681ac414f3a255abd4d8ba8579448 1001-add-basic-dns-record-parsing-functions.patch
f379f2308a8ed04560d08db90935acf56617d1b650f6227212e9ad530b53318aaecfea326ad4727439112b602a810db6857d1fe72d6e3ddeec519c99cd3608d2 1002-implement-FNM_CASEFOLD-gnu-extension.patch
dae010b45419fcab64410568466f659cdc874e63113025e2cbc2fbab047b470fec23851ecbef08886505924482a069caf37c16b483b6922535fbd31832f1c4a3 1003-remove-ulimit-fiddling-from-setxid.patch
8d3a2d5315fc56fee7da9abb8b89bb38c6046c33d154c10d168fb35bfde6b0cf9f13042a3bceee34daf091bc409d699223735dcf19f382eeee1f6be34154f26f ldconfig
+140f3f20d30bd95ebce8c41b8cc7f616c6cbedf4ea06c729c21014e74f6043796825cc40ebc5180620ea38173afdba23f09ebf6d8b11fa05440b14d23764fca9 getopt_long.c
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c
0d80f37b34a35e3d14b012257c50862dfeb9d2c81139ea2dfa101d981d093b009b9fa450ba27a708ac59377a48626971dfc58e20a3799084a65777a0c32cbc7d getconf.c
b35de9847353b273516162ed4828a810c6130fc5b7de44ee4433003b3f99647b25792d9b1c40dfc67069add11f3fb850e5c35d4f1912dccac108059bbbdfd5a2 getent.c