aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-05-20 12:45:35 -0400
committerWilliam Pitcock <nenolod@dereferenced.org>2017-05-23 22:25:16 +0000
commit3fe0df8ba95e1f631674c79ac11150fc914dfe43 (patch)
tree2338417b55ff6fdd2971a08efd4f3eeadcf93daf /main/musl
parent245c7809b92e2423c41ce71180c80f671e13dc12 (diff)
downloadaports-3fe0df8ba95e1f631674c79ac11150fc914dfe43.tar.bz2
aports-3fe0df8ba95e1f631674c79ac11150fc914dfe43.tar.xz
main/musl: update upstream s390x patch
With this update, ocaml built good but ocaml-findlib still segfault
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/0031-s390x-provide-a-working-sigcontext-struct-definition.patch47
-rw-r--r--main/musl/APKBUILD4
2 files changed, 31 insertions, 20 deletions
diff --git a/main/musl/0031-s390x-provide-a-working-sigcontext-struct-definition.patch b/main/musl/0031-s390x-provide-a-working-sigcontext-struct-definition.patch
index c65df2943a..359da6fe97 100644
--- a/main/musl/0031-s390x-provide-a-working-sigcontext-struct-definition.patch
+++ b/main/musl/0031-s390x-provide-a-working-sigcontext-struct-definition.patch
@@ -1,32 +1,43 @@
-From aaf0e610d839d82abde1da45d8ead9adbb71d2cb Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Sat, 25 Mar 2017 05:35:26 +0000
-Subject: [PATCH] s390x: provide a working sigcontext struct definition
+From 555504166852a9b9c56ac4e1fb5bb1bf20cbf8ad Mon Sep 17 00:00:00 2001
+From: Bobby Bingham <koorogi@koorogi.info>
+Date: Sun, 26 Mar 2017 14:50:37 -0500
+Subject: s390x: provide sigcontext struct definition
-For some reason, struct sigcontext was not declared on s390x (even though it is declared on every
-other architecture). Provide a workable equivalent to the structure provided by the kernel.
+This structure was missed when creating the s390x port.
-Signed-off-by: William Pitcock <nenolod@dereferenced.org>
+This is based on the report and patch from William Pitcock, but with a
+modified structure defintion to more closely match the kernel's
+definition.
---
- arch/s390x/bits/signal.h | 5 +++++
- 1 file changed, 5 insertions(+)
+ arch/s390x/bits/signal.h | 15 +++++++++++++++
+ 1 file changed, 15 insertions(+)
diff --git a/arch/s390x/bits/signal.h b/arch/s390x/bits/signal.h
-index c8665832..832351ce 100644
+index c866583..e5aca4b 100644
--- a/arch/s390x/bits/signal.h
+++ b/arch/s390x/bits/signal.h
-@@ -43,6 +43,11 @@ typedef struct {
-
- #endif
+@@ -33,6 +33,21 @@ typedef struct
+ fpregset_t fpregs;
+ } mcontext_t;
+struct sigcontext {
+ unsigned long oldmask[1];
-+ mcontext_t *sregs;
++ struct {
++ struct {
++ __psw_t psw;
++ unsigned long gprs[16];
++ unsigned acrs[16];
++ } regs;
++ struct {
++ unsigned fpc;
++ double fprs[16];
++ } fpregs;
++ } *sregs;
+};
+
- struct sigaltstack {
- void *ss_sp;
- int ss_flags;
+ #else
+
+ typedef struct {
--
-2.12.1
+cgit v0.11.2
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index cad502a1b6..ee790a95f1 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.16
-pkgrel=8
+pkgrel=9
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -199,7 +199,7 @@ dad1ed979898ddaa0a49c601160a948ba229b251307210a14240e4ebf6230b16ffc0138f396fc226
0472694cdd5a95b8df9b0e585afc7171ae9138133832ad7c0fadae4ea0a742eaa09a4d4449197ccaaefeae99c3cb7ec784068243a3a2d434429a0455c396e6bb 0028-s390x-fix-fpreg_t-and-remove-unused-per_struct.patch
33c24b895bcf1b84d90a522328b39d5b0a4aff822d0701f2f9db07a6c44c49bb3a8b16a19150c550b4fe04fad40e9af43fdf5e1fda0201e9779a471088fe9f23 0029-fix-POSIX-format-TZ-dst-transition-times-for-souther.patch
adcb5b213ebd9fc5d50cc46d4444ed64a4f928a6b4767428d7d720c6a563ba1d4a3173d6546b41379356b155a26eaad652d7b831776cc3f31e942f155db9239d 0030-fix-dlopen-dlsym-regression-opening-libs-already-loa.patch
-15ad590306829d196ecdb076d0491a822f80a46fac8179c30e29ea6b9138ebf5e1501796c8b116f8182c4ad6d1216e9702d407b7d29aeff35479f6ef568638bc 0031-s390x-provide-a-working-sigcontext-struct-definition.patch
+5601b5b56b0b2f4703ec4eb628f7eef78a130afc26979fb3d29c459cb168c62c13c3698a779ad7bbea8fb78d5f7cc02d465185a24bf9a06f6764a01fbd41dc04 0031-s390x-provide-a-working-sigcontext-struct-definition.patch
690daa7f4c7ba0d24e103299406226849ad1314e2f3ea32cc571a6cdf0bac097b24fa3efa228b03ea495d9d437c9dd90eebe7b0268f94b7e19861100f84fa66e 0032-fix-support-for-dl_iterate_phdr-in-static-pie-binaries.patch
8d3a2d5315fc56fee7da9abb8b89bb38c6046c33d154c10d168fb35bfde6b0cf9f13042a3bceee34daf091bc409d699223735dcf19f382eeee1f6be34154f26f ldconfig
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c