aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-08-07 13:24:16 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-08 07:12:21 +0000
commit2f2f995d9d52484720dbe8b4b1649c132ec1feee (patch)
tree785b0ea5376b4056461bd7cf03a050b274062762 /main/musl
parent756d41d9187e961cfed2a043f6f402049906bf08 (diff)
downloadaports-2f2f995d9d52484720dbe8b4b1649c132ec1feee.tar.bz2
aports-2f2f995d9d52484720dbe8b4b1649c132ec1feee.tar.xz
main/musl: fix /usr/bin/ldd to accept cli params
remove ' --' from exec line to allow passing parameters prefixed with -- bump pkgrel
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index e9a2ce9028..af6b388687 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.23
-pkgrel=2
+pkgrel=3
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -98,7 +98,7 @@ package() {
cat >>"$pkgdir"/usr/bin/ldd <<-EOF
#!/bin/sh
- exec /lib/$LDSO --list -- "\$@"
+ exec /lib/$LDSO --list "\$@"
EOF
chmod 755 "$pkgdir"/usr/bin/ldd
fi