aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-06 11:01:31 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-06 11:06:30 +0000
commit0c3bccdda5e5b537c5b2af064505e05d772df70f (patch)
treee803c9113ef7dc81ada9f909d0b40116daac6778 /main/musl
parent6412f70fcbbfbddf82d0c91134149573f65fc28d (diff)
downloadaports-0c3bccdda5e5b537c5b2af064505e05d772df70f.tar.bz2
aports-0c3bccdda5e5b537c5b2af064505e05d772df70f.tar.xz
main/musl: fix arch, support crosscompiler creation
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/APKBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 5d334325a3..a55f6657a4 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.9.13
pkgrel=0
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
-arch="x86 x86_64 arm armel"
+arch="all"
license="MIT"
depends=""
depends_dev=""
@@ -33,8 +33,21 @@ prepare() {
cp "$srcdir"/getopt_long.c src/misc/
}
+install_sysroot_headers() {
+ cd "$_builddir"
+ if [ -z "${CBUILDROOT}" ]; then
+ echo "CBUILDROOT not must be set!"
+ return 1
+ fi
+ case "$CARCH" in
+ arm*) ARCH="arm" ;;
+ x86) ARCH="i386" ;;
+ x86_64) ARCH="x86_64" ;;
+ esac
+ make ARCH="$ARCH" DESTDIR="${CBUILDROOT}" install-headers || return 1
+}
+
build() {
- local _ldflags
cd "$_builddir"
# note: not autotools
LDFLAGS="$LDFLAGS -Wl,-soname,libc.musl-${CARCH}.so.1" \