aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-18 12:10:04 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-18 12:10:04 +0000
commit4e222b34c6b359284ac9729bdd8ab7ca0632ae20 (patch)
tree15490cff925b13ff6d45829eca8040cc24b5f591 /main/musl
parente4abece5cdfbd21c39995fec059af885089186e6 (diff)
downloadaports-4e222b34c6b359284ac9729bdd8ab7ca0632ae20.tar.bz2
aports-4e222b34c6b359284ac9729bdd8ab7ca0632ae20.tar.xz
main/musl: add patches for tcp socket option structs and herror
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/1004-define-and-implement-herror.patch55
-rw-r--r--main/musl/1005-add-TCP_INFO-and-TCP_MD5SIG-socket-option-related-st.patch81
-rw-r--r--main/musl/APKBUILD10
3 files changed, 145 insertions, 1 deletions
diff --git a/main/musl/1004-define-and-implement-herror.patch b/main/musl/1004-define-and-implement-herror.patch
new file mode 100644
index 0000000000..0935dff6c8
--- /dev/null
+++ b/main/musl/1004-define-and-implement-herror.patch
@@ -0,0 +1,55 @@
+From 2a21ef4263d853616df24cc8e4c00f5a2c2980e9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Wed, 18 Dec 2013 13:24:06 +0200
+Subject: [PATCH] define and implement herror
+
+---
+ include/netdb.h | 1 +
+ src/network/herror.c | 23 +++++++++++++++++++++++
+ 2 files changed, 24 insertions(+)
+ create mode 100644 src/network/herror.c
+
+diff --git a/include/netdb.h b/include/netdb.h
+index 8a7013a..2dd799b 100644
+--- a/include/netdb.h
++++ b/include/netdb.h
+@@ -134,6 +134,7 @@ int *__h_errno_location(void);
+ #endif
+
+ #if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
++void herror(const char *);
+ const char *hstrerror(int);
+ int gethostbyname_r(const char *, struct hostent *, char *, size_t, struct hostent **, int *);
+ int gethostbyname2_r(const char *, int, struct hostent *, char *, size_t, struct hostent **, int *);
+diff --git a/src/network/herror.c b/src/network/herror.c
+new file mode 100644
+index 0000000..25117a3
+--- /dev/null
++++ b/src/network/herror.c
+@@ -0,0 +1,23 @@
++#define _GNU_SOURCE
++#include <stdio.h>
++#include <string.h>
++#include <netdb.h>
++#include "stdio_impl.h"
++
++void herror(const char *msg)
++{
++ FILE *f = stderr;
++ const char *errstr = hstrerror(h_errno);
++
++ FLOCK(f);
++
++ if (msg && *msg) {
++ fwrite(msg, strlen(msg), 1, f);
++ fputc(':', f);
++ fputc(' ', f);
++ }
++ fwrite(errstr, strlen(errstr), 1, f);
++ fputc('\n', f);
++
++ FUNLOCK(f);
++}
+--
+1.8.5.1
+
diff --git a/main/musl/1005-add-TCP_INFO-and-TCP_MD5SIG-socket-option-related-st.patch b/main/musl/1005-add-TCP_INFO-and-TCP_MD5SIG-socket-option-related-st.patch
new file mode 100644
index 0000000000..7af697cdc3
--- /dev/null
+++ b/main/musl/1005-add-TCP_INFO-and-TCP_MD5SIG-socket-option-related-st.patch
@@ -0,0 +1,81 @@
+From 38c01bb8b97d911d3eb5d1ab48ad40c0857f78cb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Wed, 18 Dec 2013 13:53:11 +0200
+Subject: [PATCH] add TCP_INFO and TCP_MD5SIG socket option related structures
+
+---
+ include/netinet/tcp.h | 58 +++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 58 insertions(+)
+
+diff --git a/include/netinet/tcp.h b/include/netinet/tcp.h
+index 5212ef7..5639b89 100644
+--- a/include/netinet/tcp.h
++++ b/include/netinet/tcp.h
+@@ -79,6 +79,64 @@ struct tcphdr
+ u_int16_t check;
+ u_int16_t urg_ptr;
+ };
++
++#define TCPI_OPT_TIMESTAMPS 1
++#define TCPI_OPT_SACK 2
++#define TCPI_OPT_WSCALE 4
++#define TCPI_OPT_ECN 8
++
++#define TCP_CA_Open 0
++#define TCP_CA_Disorder 1
++#define TCP_CA_CWR 2
++#define TCP_CA_Recovery 3
++#define TCP_CA_Loss 4
++
++struct tcp_info
++{
++ u_int8_t tcpi_state;
++ u_int8_t tcpi_ca_state;
++ u_int8_t tcpi_retransmits;
++ u_int8_t tcpi_probes;
++ u_int8_t tcpi_backoff;
++ u_int8_t tcpi_options;
++ u_int8_t tcpi_snd_wscale : 4, tcpi_rcv_wscale : 4;
++ u_int32_t tcpi_rto;
++ u_int32_t tcpi_ato;
++ u_int32_t tcpi_snd_mss;
++ u_int32_t tcpi_rcv_mss;
++ u_int32_t tcpi_unacked;
++ u_int32_t tcpi_sacked;
++ u_int32_t tcpi_lost;
++ u_int32_t tcpi_retrans;
++ u_int32_t tcpi_fackets;
++ u_int32_t tcpi_last_data_sent;
++ u_int32_t tcpi_last_ack_sent;
++ u_int32_t tcpi_last_data_recv;
++ u_int32_t tcpi_last_ack_recv;
++ u_int32_t tcpi_pmtu;
++ u_int32_t tcpi_rcv_ssthresh;
++ u_int32_t tcpi_rtt;
++ u_int32_t tcpi_rttvar;
++ u_int32_t tcpi_snd_ssthresh;
++ u_int32_t tcpi_snd_cwnd;
++ u_int32_t tcpi_advmss;
++ u_int32_t tcpi_reordering;
++ u_int32_t tcpi_rcv_rtt;
++ u_int32_t tcpi_rcv_space;
++ u_int32_t tcpi_total_retrans;
++};
++
++#define TCP_MD5SIG_MAXKEYLEN 80
++
++struct tcp_md5sig
++{
++ struct sockaddr_storage tcpm_addr;
++ u_int16_t __tcpm_pad1;
++ u_int16_t tcpm_keylen;
++ u_int32_t __tcpm_pad2;
++ u_int8_t tcpm_key[TCP_MD5SIG_MAXKEYLEN];
++};
++
+ #endif
+
+ #endif
+--
+1.8.5.1
+
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index c517306306..035eba463c 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=0.9.14
-pkgrel=8
+pkgrel=9
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -19,6 +19,8 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
1001-add-basic-dns-record-parsing-functions.patch
1002-add-sys-quota.h-and-quotactl-syscall-wrapper.patch
1003-add-netinet-igmp.h-and-multicast-groups-to-netinet-i.patch
+ 1004-define-and-implement-herror.patch
+ 1005-add-TCP_INFO-and-TCP_MD5SIG-socket-option-related-st.patch
2001-workaround-gcc-pr58245.patch
@@ -116,6 +118,8 @@ de075c4b6ff2bf406f437d100f06c6bd 0001-updates-from-git.patch
a3810683ef61ac27e2f6ec9801280c81 1001-add-basic-dns-record-parsing-functions.patch
06a67be89404258c321c08348cb547ce 1002-add-sys-quota.h-and-quotactl-syscall-wrapper.patch
bb7b6eb67c1749943f378c88acc48e5c 1003-add-netinet-igmp.h-and-multicast-groups-to-netinet-i.patch
+fcf15ee683ea241ad26330c28934fa27 1004-define-and-implement-herror.patch
+e46d5241827593673a3d8f1a6b8bacdc 1005-add-TCP_INFO-and-TCP_MD5SIG-socket-option-related-st.patch
7a09c5cd7b3e9532e6902f54a5e928bb 2001-workaround-gcc-pr58245.patch
61c6c1e84ed1df82abbe6d75e90cf21c getopt_long.c
0df687757221bbb0fc1aa67f1bd646f9 __stack_chk_fail_local.c
@@ -126,6 +130,8 @@ d8e303e61f2cc220ce2b7ffd992d37406b87dd2a4062f61f5de3e0df144227b0 0001-updates-f
758390768b1bc4159d56908ca332b9640cd0552ed3b4b2b8d4a6d499c54c11a1 1001-add-basic-dns-record-parsing-functions.patch
4ef5ae263b55c0c691c5fb212bcdaa2050091e6acfa2a6dffc597db9743b8c53 1002-add-sys-quota.h-and-quotactl-syscall-wrapper.patch
f57dee5a9309055b298056e4d4107c67e3b0d5f164ab277ffcb353fb1688a2d2 1003-add-netinet-igmp.h-and-multicast-groups-to-netinet-i.patch
+995d3e6a7013f220cf3fdeae7ebfd84a1dc2517ebf53e712ab10c8b379e8ac9e 1004-define-and-implement-herror.patch
+2fb0f1b6f7f0092f5f8f144cede321ad375379e93805440af538d2be846d0c24 1005-add-TCP_INFO-and-TCP_MD5SIG-socket-option-related-st.patch
45d6efda7450809e4e68f6e951431dcadf6cb7f0260930d50a9f1a8667aca49f 2001-workaround-gcc-pr58245.patch
d9b644ec20bc33e81a7c52b9fcf7973d835923a69faf50f03db45534b811bd96 getopt_long.c
299a7d75a09de3e2e11e7fb4acc3182e4a14e868093d2f30938fce9bfcff13da __stack_chk_fail_local.c
@@ -136,6 +142,8 @@ sha512sums="e5c3f7b1549dc2f9cbd3359cc413f761d5967607c23705f651c33d0ae93f00582193
dad965258daf69371b844f76bfe5a914b0eca0ca76f3fc340b8fd7acf598b5f87bbe6d68b1f43ed0293ee0ed3bfd85d5173ccc169aa6265646248d5b8a906708 1001-add-basic-dns-record-parsing-functions.patch
c64a8c5fa7f0ad095e9281cf23eeed70f476adadb044eb8ac8e038153fd19accf601d82cf89dc289c933b7cbfce3e59ba6c03fa5f7a3a63038905453b5b152a1 1002-add-sys-quota.h-and-quotactl-syscall-wrapper.patch
a8bb390658552b766c1d92cf261bc77bd2369cd185d9803f2ba0265713de16f812dfe916a4d1b428bf5073848741800d856571009042e7514098344d31751f45 1003-add-netinet-igmp.h-and-multicast-groups-to-netinet-i.patch
+c510abb133aedc25a421837ee9e8e02d22d512fab2534d7ac612c2df1df28484d4a7e9ccef0ceec85ba2fb27ecea916d242dfbfff13159d22c4da4757a06e4f5 1004-define-and-implement-herror.patch
+a6bd33dcd80a525b9aacb5947ed294fd67148b83c02b139dcb8af39aaff0a27964aa6a640b07331d0f433df22ca3f177d7422b61917d42307cefddf7352002e5 1005-add-TCP_INFO-and-TCP_MD5SIG-socket-option-related-st.patch
69ad3fc851b44f33dd7c98b83fd0adbd149b37263d17b989f4d7338ee0703dfe8994f4299744e2509492300227d652de6f21b6cdba9b633fcefd3d9f7ca0cf20 2001-workaround-gcc-pr58245.patch
140f3f20d30bd95ebce8c41b8cc7f616c6cbedf4ea06c729c21014e74f6043796825cc40ebc5180620ea38173afdba23f09ebf6d8b11fa05440b14d23764fca9 getopt_long.c
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c