aboutsummaryrefslogtreecommitdiffstats
path: root/main/nasm
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2018-12-24 11:15:14 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-06 14:27:44 +0000
commitac006af238a48a25f554b958554e03800684d316 (patch)
tree7110b22cff982b5bcf5d9815beed33f427531ff7 /main/nasm
parentce2c8c257fd929fe9768e27a8526d0439cd42dd8 (diff)
downloadaports-ac006af238a48a25f554b958554e03800684d316.tar.bz2
aports-ac006af238a48a25f554b958554e03800684d316.tar.xz
main/nasm: Update to 2.14.01
Diffstat (limited to 'main/nasm')
-rw-r--r--main/nasm/APKBUILD11
-rw-r--r--main/nasm/drop-unused-seg_init.patch32
2 files changed, 4 insertions, 39 deletions
diff --git a/main/nasm/APKBUILD b/main/nasm/APKBUILD
index db195d7d81..7e697887a0 100644
--- a/main/nasm/APKBUILD
+++ b/main/nasm/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nasm
-pkgver=2.13.03
+pkgver=2.14.01
pkgrel=0
pkgdesc="80x86 assembler designed for portability and modularity"
url="https://www.nasm.us"
@@ -8,9 +8,7 @@ arch="all"
license="BSD-2-Clause"
checkdepends="perl"
subpackages="$pkgname-doc"
-source="https://www.nasm.us/pub/nasm/releasebuilds/$pkgver/$pkgname-$pkgver.tar.bz2
- drop-unused-seg_init.patch
- "
+source="https://www.nasm.us/pub/nasm/releasebuilds/$pkgver/$pkgname-$pkgver.tar.bz2"
build () {
cd "$builddir"
@@ -30,8 +28,7 @@ check() {
package() {
cd "$builddir"
- make INSTALLROOT="$pkgdir" install
+ make DESTDIR="$pkgdir" install
}
-sha512sums="d7a6b4cee8dfd603d8d4c976e5287b5cc542fa0b466ff989b743276a6e28114e64289bf02a7819eca63142a5278aa6eed57773007e5f589e15768e6456a8919d nasm-2.13.03.tar.bz2
-cbf082919c9d455f5dcc0e073f3f79869049d35bb37c269c4690f69e71454f533259d431a907eb6edf1e0e40793473d711caf65e225e15b2ba0380f06e3479eb drop-unused-seg_init.patch"
+sha512sums="38527bb508d271c2f8f57ed15e250c63e2480223c14f121837120d6e71ca8f1cd5337b531add88c81bac4515d60a885ce7004b687110b6223c927b18ddf2030e nasm-2.14.01.tar.bz2"
diff --git a/main/nasm/drop-unused-seg_init.patch b/main/nasm/drop-unused-seg_init.patch
deleted file mode 100644
index 5e6b53028e..0000000000
--- a/main/nasm/drop-unused-seg_init.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 5eb1838b4d3752fd863d19442943983a2a5ee87c Mon Sep 17 00:00:00 2001
-From: Cyrill Gorcunov <gorcunov@gmail.com>
-Date: Sat, 10 Feb 2018 00:33:41 +0300
-Subject: [PATCH] nasmlib: Drop unused seg_init
-
-The helper has been eliminated in 2c4a4d5810d0a59b033a07876a2648ef5d4c2859
-
-https://bugzilla.nasm.us/show_bug.cgi?id=3392461
-
-Signed-off-by: Cyrill Gorcunov <gorcunov@gmail.com>
----
- include/nasmlib.h | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/include/nasmlib.h b/include/nasmlib.h
-index 79e866b..fee1b5e 100644
---- a/include/nasmlib.h
-+++ b/include/nasmlib.h
-@@ -188,10 +188,8 @@ int64_t readnum(char *str, bool *error);
- int64_t readstrnum(char *str, int length, bool *warn);
-
- /*
-- * seg_init: Initialise the segment-number allocator.
- * seg_alloc: allocate a hitherto unused segment number.
- */
--void pure_func seg_init(void);
- int32_t pure_func seg_alloc(void);
-
- /*
---
-2.10.5.GIT
-