aboutsummaryrefslogtreecommitdiffstats
path: root/main/ndctl
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-11-12 20:32:20 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-11-12 20:32:20 +0000
commit171da304a397a5770a2ded969abe19894ee64793 (patch)
treea1a147adb20d315aa8a5070b3cfe9fded390e01f /main/ndctl
parent410c029fa080824d026bde4a1ce0fc4833d44b89 (diff)
downloadaports-171da304a397a5770a2ded969abe19894ee64793.tar.bz2
aports-171da304a397a5770a2ded969abe19894ee64793.tar.xz
main/ndctl: fix build version
Due to lack of a version file, ndctl tries to get a version from the current git repository, which is aports. This leads to build failures, because the version that it ends up with is invalid: ``` ERROR: ndctl-dev*: usr/lib/pkgconfig/libdaxctl.pc: pkgconf version 67.git410c029f is invalid ``` This can be fixed by creating a `version` file with the actual version in it.
Diffstat (limited to 'main/ndctl')
-rw-r--r--main/ndctl/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/ndctl/APKBUILD b/main/ndctl/APKBUILD
index bc575b385e..009aeca9bb 100644
--- a/main/ndctl/APKBUILD
+++ b/main/ndctl/APKBUILD
@@ -17,7 +17,7 @@ options="!check" # tests require building & loading the nfit_test.ko kernel modu
prepare() {
default_prepare
- cd "$builddir"
+ echo $pkgver >"$builddir/version"
./autogen.sh
}