aboutsummaryrefslogtreecommitdiffstats
path: root/main/nettle
diff options
context:
space:
mode:
authorRobert Yang <decatf@gmail.com>2019-02-07 21:53:29 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-08 10:12:15 +0000
commitc294df6e8d2e92a4304a273be6fe4b59810e9e27 (patch)
tree28320c8089f8b5f723086a078609eada9298e714 /main/nettle
parent5973fb6a004dc3190aeb7831c0e24714c507158c (diff)
downloadaports-c294df6e8d2e92a4304a273be6fe4b59810e9e27.tar.bz2
aports-c294df6e8d2e92a4304a273be6fe4b59810e9e27.tar.xz
main/nettle: disable neon for arch armv7
A previous commit ensures arm neon is disabled for armhf: 36a1b9b653eb45ae33735f906d3e7ff6e4d61365 Extend this to armv7 as well. It uses vfpv3-d16 fpu which doesn't include neon instruction set.
Diffstat (limited to 'main/nettle')
-rw-r--r--main/nettle/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/nettle/APKBUILD b/main/nettle/APKBUILD
index 805c3c6fec..e02c9d8d24 100644
--- a/main/nettle/APKBUILD
+++ b/main/nettle/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=nettle
pkgver=3.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="A low-level cryptographic library"
url="http://www.lysator.liu.se/~nisse/nettle/"
arch="all"
@@ -17,7 +17,13 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
builddir="$srcdir/$pkgname-$pkgver"
build() {
- [ "$CARCH" = "armhf" ] && local _ARM_NEON="--disable-arm-neon"
+ local _arch_opts=
+
+ case "$CARCH" in
+ armhf|armv7)
+ _arch_opts="--disable-arm-neon"
+ esac
+
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -30,7 +36,7 @@ build() {
--localstatedir=/var \
--enable-shared \
--disable-openssl \
- $_ARM_NEON
+ $_arch_opts
make
# strip comments in fields from .pc as it confuses pkgconf
sed -i -e 's/ \#.*//' *.pc