aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx-initscripts
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-09-05 12:37:43 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-05 13:05:36 +0200
commita06bd137ccd148f57e09f5ec9afcff356bac3b7c (patch)
treeb8d4bd57eb51bacee8395eef558be3782f79a183 /main/nginx-initscripts
parent41e3fcac3cc4577b885f3629ecf0c0f99bb7ac7a (diff)
downloadaports-a06bd137ccd148f57e09f5ec9afcff356bac3b7c.tar.bz2
aports-a06bd137ccd148f57e09f5ec9afcff356bac3b7c.tar.xz
main/nginx-initscripts: move initscripts to shared package
Share the openrc initscript for the different nginx builds.
Diffstat (limited to 'main/nginx-initscripts')
-rw-r--r--main/nginx-initscripts/APKBUILD44
-rw-r--r--main/nginx-initscripts/nginx-initscripts.pre-install9
l---------main/nginx-initscripts/nginx-initscripts.pre-upgrade1
-rw-r--r--main/nginx-initscripts/nginx.initd69
-rw-r--r--main/nginx-initscripts/nginx.logrotate12
5 files changed, 135 insertions, 0 deletions
diff --git a/main/nginx-initscripts/APKBUILD b/main/nginx-initscripts/APKBUILD
new file mode 100644
index 0000000000..3d263bc1b2
--- /dev/null
+++ b/main/nginx-initscripts/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+pkgname=nginx-initscripts
+pkgver=1.8.0
+pkgrel=0
+pkgdesc="initscripts and logrotate config for nginx"
+url="http://www.nginx.org"
+arch="noarch"
+license="nginx"
+pkgusers="nginx"
+pkggroups="nginx"
+install="$pkgname.pre-install $pkgname.pre-upgrade"
+replaces="nginx nginx-lua"
+makedepends=""
+subpackages=""
+source="nginx.initd
+ nginx.logrotate
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ return 0
+}
+
+build() {
+ return 0
+}
+
+package() {
+ install -m755 -D "$srcdir"/nginx.initd \
+ "$pkgdir"/etc/init.d/nginx \
+ || return 1
+ install -m644 -D "$srcdir"/nginx.logrotate \
+ "$pkgdir"/etc/logrotate.d/nginx \
+ || return 1
+}
+
+md5sums="e6c76d4ffbb8549600e03e9e0f4d2dbe nginx.initd
+d3f30c25c84c55252a6babd9e9b0325b nginx.logrotate"
+sha256sums="6dcb7739f97ae86d4a09e12126546bcab0f87da093d78167dcf9f220194ed68b nginx.initd
+6b89872994508cc7b4b225bca3301d7942767f37b8b691134141d95995740890 nginx.logrotate"
+sha512sums="9d645248130ec35183f05efdd5a6b2a911f706348c5efc3bcc29ee88cc02ee68117ca3c7f532115c04db344818fa4a9fd7e31995efbf52e2d963bec568d0c69f nginx.initd
+fda91710185d6b801dd746c8c3678b5719b408de0b715bef7b1985f1ee17db1e8378d440759ea6234b1f70454a35870a2917bd1d6cd309ddc70e1c066fc8d4b8 nginx.logrotate"
diff --git a/main/nginx-initscripts/nginx-initscripts.pre-install b/main/nginx-initscripts/nginx-initscripts.pre-install
new file mode 100644
index 0000000000..55b5bfcda5
--- /dev/null
+++ b/main/nginx-initscripts/nginx-initscripts.pre-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+addgroup -g 82 -S www-data 2>/dev/null
+addgroup -S nginx 2>/dev/null
+adduser -S -G nginx -H -h /var/www/localhost/htdocs -s /sbin/nologin \
+ -D nginx 2>/dev/null
+addgroup nginx www-data 2>/dev/null
+
+exit 0
diff --git a/main/nginx-initscripts/nginx-initscripts.pre-upgrade b/main/nginx-initscripts/nginx-initscripts.pre-upgrade
new file mode 120000
index 0000000000..fabdc1c0f3
--- /dev/null
+++ b/main/nginx-initscripts/nginx-initscripts.pre-upgrade
@@ -0,0 +1 @@
+nginx-initscripts.pre-install \ No newline at end of file
diff --git a/main/nginx-initscripts/nginx.initd b/main/nginx-initscripts/nginx.initd
new file mode 100644
index 0000000000..b1e0fe7856
--- /dev/null
+++ b/main/nginx-initscripts/nginx.initd
@@ -0,0 +1,69 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/files/nginx.init-r2,v 1.1 2010/01/03 19:51:41 djc Exp $
+
+extra_started_commands="upgrade reload"
+extra_commands="configtest"
+
+conffile=/etc/nginx/nginx.conf
+
+pidfile=/var/run/nginx/nginx.pid
+command=/usr/sbin/nginx
+command_args="-c $conffile"
+
+
+depend() {
+ need net
+ use dns logger netmount
+}
+
+start_pre() {
+ configtest || return 1
+}
+
+reload() {
+ configtest || return 1
+ ebegin "Refreshing nginx' configuration"
+ kill -HUP `cat $pidfile` &>/dev/null
+ eend $? "Failed to reload nginx"
+}
+
+upgrade() {
+ configtest || return 1
+ ebegin "Upgrading nginx"
+
+ einfo "Sending USR2 to old binary"
+ kill -USR2 `cat $pidfile` &>/dev/null
+
+ einfo "Sleeping 3 seconds before pid-files checking"
+ sleep 3
+
+ if [ ! -f $pidfile.oldbin ]; then
+ eerror "File with old pid ($pidfile.oldbin) not found"
+ return 1
+ fi
+
+ if [ ! -f $pidfile ]; then
+ eerror "New binary failed to start"
+ return 1
+ fi
+
+ einfo "Sleeping 3 seconds before WINCH"
+ sleep 3 ; kill -WINCH `cat $pidfile.oldbin`
+
+ einfo "Sending QUIT to old binary"
+ kill -QUIT `cat $pidfile.oldbin`
+
+ einfo "Upgrade completed"
+
+ eend $? "Upgrade failed"
+}
+
+configtest() {
+ ebegin "Checking nginx' configuration"
+ checkpath --directory --owner nginx:nginx ${pidfile%/*}
+ $command -c $conffile -tq
+ eend $? "failed, please correct errors above"
+}
+
diff --git a/main/nginx-initscripts/nginx.logrotate b/main/nginx-initscripts/nginx.logrotate
new file mode 100644
index 0000000000..00e5a94eb5
--- /dev/null
+++ b/main/nginx-initscripts/nginx.logrotate
@@ -0,0 +1,12 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/files/nginx.logrotate,v 1.1 2010/01/03 20:29:40 djc Exp $
+
+/var/log/nginx/*.log {
+ missingok
+ sharedscripts
+ postrotate
+ test -r /var/run/nginx.pid && kill -USR1 `cat /var/run/nginx.pid`
+ endscript
+}
+