aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx/APKBUILD
diff options
context:
space:
mode:
authoraptalca <aptalca@linuxserver.io>2019-08-14 14:36:20 -0400
committerJakub Jirutka <jakub@jirutka.cz>2019-10-26 16:33:46 +0200
commitf29c859c687342147661b62edb89d3f890877c3b (patch)
tree6a836890a5d7a8f05e053b5692008cac561fd64a /main/nginx/APKBUILD
parentf2bf0e68a9a595872b2d0f1fdd39576bca5f2d6c (diff)
downloadaports-f29c859c687342147661b62edb89d3f890877c3b.tar.bz2
aports-f29c859c687342147661b62edb89d3f890877c3b.tar.xz
main/nginx: fix support for more so libs per module
When there is more than one so defined for a module, the line echo "load_module \"modules/$soname\";" > ./etc/nginx/modules/$name.conf only writes the last so listed into the conf file. Related to GH-9234
Diffstat (limited to 'main/nginx/APKBUILD')
-rw-r--r--main/nginx/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 846c7ff665..d51ff8cba6 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -339,7 +339,7 @@ _module() {
local soname; for soname in $sonames; do
mv "$pkgdir"/$_modules_dir/$soname ./$_modules_dir/$soname
- echo "load_module \"modules/$soname\";" > ./etc/nginx/modules/$name.conf
+ echo "load_module \"modules/$soname\";" >> ./etc/nginx/modules/$name.conf
done
case "$name" in