aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authoraptalca <aptalca@linuxserver.io>2019-03-19 19:39:22 -0400
committerJakub Jirutka <jakub@jirutka.cz>2019-05-07 00:35:21 +0200
commitff3a47ccfe8ed9d0b87359b176019114b7158807 (patch)
tree64f1368d4ef4fe1b0272b5e2343bcbf0fcbc6340 /main/nginx
parent1943bfff71c5335afdb7ad53ce0f13f7e79883a7 (diff)
downloadaports-ff3a47ccfe8ed9d0b87359b176019114b7158807.tar.bz2
aports-ff3a47ccfe8ed9d0b87359b176019114b7158807.tar.xz
main/nginx: add http-geoip2 module
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index a98b81ad3f..704906364a 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -15,7 +15,7 @@ pkgname=nginx
# NOTE: Upgrade only to even-numbered versions (e.g. 1.14.z, 1.16.z)!
# Odd-numbered versions are mainline (development) versions.
pkgver=1.16.0
-pkgrel=0
+pkgrel=1
# Revision of nginx-tests to use for check().
_tests_hgrev=2be630357aa7
_njs_ver=0.3.1
@@ -27,6 +27,7 @@ depends=""
makedepends="
gd-dev
geoip-dev
+ libmaxminddb-dev
libxml2-dev
libxslt-dev
linux-headers
@@ -139,6 +140,8 @@ _rtmp_provides="$pkgname-rtmp" # for backward compatibility
_add_module "http-vod" "1.24" "https://github.com/kaltura/nginx-vod-module"
+_add_module "http-geoip2" "3.2" "https://github.com/leev/ngx_http_geoip2_module"
+
prepare() {
local file; for file in $source; do
case $file in
@@ -325,4 +328,5 @@ d6ca250db8de93edbd7875afca35e73cecdaf82132d1a7ee933cf94c6b8afa8e629e9e647a9321f2
c31c46344d49704389722325a041b9cd170fa290acefe92cfc572c07f711cd3039de78f28df48ca7dcb79b2e4bbe442580aaaf4d92883fd3a14bf41d66dd9d8c nginx-upload-progress-module-0.9.2.tar.gz
8adb7453c27748f4e685e3352e9b318b408da818754dc5b6244e908423941a8ba337561104f6e481f2553cbc0e334dcea73b57f8e810a9d6e974bb69ff8859e5 nginx-upstream-fair-0.1.3.tar.gz
4a0af5e9afa4deb0b53de8de7ddb2cfa6430d372e1ef9e421f01b509548bd134d427345442ac1ce667338cc2a1484dc2ab732e316e878ac7d3537dc527d5f922 nginx-rtmp-module-1.2.1.tar.gz
-daa9b23858937e57f1bcd5f4400b33155ab4e0e455eea01d80eec5285fc85bd10db63d80a1560f1fea51914a4eb4c59cc54110b7e4de208adbf52ea691cfd6d9 nginx-vod-module-1.24.tar.gz"
+daa9b23858937e57f1bcd5f4400b33155ab4e0e455eea01d80eec5285fc85bd10db63d80a1560f1fea51914a4eb4c59cc54110b7e4de208adbf52ea691cfd6d9 nginx-vod-module-1.24.tar.gz
+84b26955234e29dbfbf2431b652fcc453c5e86b95f837296df4f3d6c730e3e0773223dae890eebfc9b5763f46082bde6f38d6505b8bf78133b89e7297016cc5d ngx_http_geoip2_module-3.2.tar.gz"