aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-07 09:56:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-07 11:24:09 +0000
commitca01497574244b8c178d669329eed2b8cb497957 (patch)
tree5a60cb6b3cb943b4cb3105698a738c67199fdfab /main/nginx
parent50f7864e9d43b66a0a86b3f796b5b066bff7290d (diff)
downloadaports-ca01497574244b8c178d669329eed2b8cb497957.tar.bz2
aports-ca01497574244b8c178d669329eed2b8cb497957.tar.xz
main/nginx: disable lua-nginx-module on s390x
lua-nginx-modules requires luajit since 0.10.14 and luajit does not yet support s390x. This fixes build of nginx on s390x
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 121b297477..cdf5c4bb2a 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -69,8 +69,9 @@ _modules_dir="usr/lib/$pkgname/modules"
_stream_js_depends="$pkgname-mod-stream"
# luajit is not available for s390x.
+_skip_luajit=
case "$CARCH" in
- s390x) makedepends="$makedepends lua5.1-dev";;
+ s390x) makedepends="$makedepends lua5.1-dev"; _skip_luajit=true;;
*) makedepends="$makedepends luajit-dev";;
esac
@@ -93,12 +94,16 @@ done
# For simplicity we assume that module is hosted on GitHub.
_add_module() {
- local name="$1" ver="$2" url="$3"
+ local name="$1" ver="$2" url="$3" skip="$4"
local dirname="${url##*/}-${ver#v}"
- subpackages="$subpackages $pkgname-mod-$name:_module"
+ # we need to include source even if module is skipped for this architecture,
+ # due to the static checksums list.
source="$source $dirname.tar.gz::$url/archive/$ver.tar.gz"
- _extra_flags="$_extra_flags --add-dynamic-module=$srcdir/$dirname"
+ if [ -z "$skip" ]; then
+ subpackages="$subpackages $pkgname-mod-$name:_module"
+ _extra_flags="$_extra_flags --add-dynamic-module=$srcdir/$dirname"
+ fi
}
_add_module "devel-kit" "v0.3.0" "https://github.com/simpl/ngx_devel_kit"
@@ -113,11 +118,12 @@ _add_module "http-fancyindex" "v0.4.3" "https://github.com/aperezdc/ngx-fancyind
_add_module "http-headers-more" "v0.33" "https://github.com/openresty/headers-more-nginx-module"
_http_headers_more_so="ngx_http_headers_more_filter_module.so"
-_add_module "http-lua" "v0.10.15" "https://github.com/openresty/lua-nginx-module"
+# luajit is required for lua-nginx-module since v0.10.14
+_add_module "http-lua" "v0.10.15" "https://github.com/openresty/lua-nginx-module" $_skip_luajit
_http_lua_depends="$pkgname-mod-devel-kit"
_http_lua_provides="$pkgname-lua" # for backward compatibility
-_add_module "http-lua-upstream" "v0.07" "https://github.com/openresty/lua-upstream-nginx-module"
+_add_module "http-lua-upstream" "v0.07" "https://github.com/openresty/lua-upstream-nginx-module" $_skip_luajit
_http_lua_upstream_depends="$pkgname-mod-http-lua"
_add_module "http-nchan" "v1.2.5" "https://github.com/slact/nchan"