aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-10 01:27:03 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-10 01:32:43 +0200
commitb3e49e27426db111c86baf291134fc8eed4157b8 (patch)
tree333c65aa1cfa6cae308505641d36c9a1d968b005 /main/nginx
parentc5f742df3da1536cf6154e30f5b50da7582df988 (diff)
downloadaports-b3e49e27426db111c86baf291134fc8eed4157b8.tar.bz2
aports-b3e49e27426db111c86baf291134fc8eed4157b8.tar.xz
main/nginx: add subpackage -mod-http-nchan
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 51faad3eae..43618626c5 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -5,7 +5,7 @@
pkgname=nginx
pkgver=1.10.1
-pkgrel=7
+pkgrel=8
pkgdesc="HTTP and reverse proxy server"
url="http://www.nginx.org/en"
arch="all"
@@ -36,6 +36,11 @@ _http_lua_dir="$srcdir/$_http_lua_name-$_http_lua_ver"
_http_lua_depends="$pkgname-mod-devel-kit"
_http_lua_provides="$pkgname-lua" # for backward compatibility
+_http_nchan_name=nchan
+_http_nchan_ver=1.0.3
+_http_nchan_dir="$srcdir/$_http_nchan_name-$_http_nchan_ver"
+_http_nchan_so="ngx_nchan_module.so"
+
_http_upload_progress_name=nginx-upload-progress-module
_http_upload_progress_ver=0.9.2
_http_upload_progress_dir="$srcdir/$_http_upload_progress_name-$_http_upload_progress_ver"
@@ -62,6 +67,7 @@ source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
$_http_fancyindex_name-$_http_fancyindex_ver.tar.gz::https://github.com/aperezdc/$_http_fancyindex_name/archive/v$_http_fancyindex_ver.tar.gz
$_http_headers_more_name-$_http_headers_more_ver.tar.gz::https://github.com/openresty/$_http_headers_more_name/archive/v$_http_headers_more_ver.tar.gz
$_http_lua_name-$_http_lua_ver.tar.gz::https://github.com/openresty/$_http_lua_name/archive/v$_http_lua_ver.tar.gz
+ $_http_nchan_name-$_http_nchan_ver.tar.gz::https://github.com/slact/$_http_nchan_name/archive/v$_http_nchan_ver.tar.gz
$_http_upload_progress_name-$_http_upload_progress_ver.tar.gz::https://github.com/masterzen/$_http_upload_progress_name/archive/v$_http_upload_progress_ver.tar.gz
$_rtmp_name-$_rtmp_ver.tar.gz::https://github.com/arut/$_rtmp_name/archive/v$_rtmp_ver.tar.gz
nginx.conf
@@ -85,6 +91,7 @@ _modules="
http-fancyindex
http-headers-more
http-lua
+ http-nchan
http-upload-progress
rtmp"
for _m in $_modules; do
@@ -146,6 +153,7 @@ build() {
--add-dynamic-module="$_http_fancyindex_dir" \
--add-dynamic-module="$_http_headers_more_dir" \
--add-dynamic-module="$_http_lua_dir" \
+ --add-dynamic-module="$_http_nchan_dir" \
--add-dynamic-module="$_http_upload_progress_dir" \
--add-dynamic-module="$_rtmp_dir" \
|| return 1
@@ -232,6 +240,7 @@ md5sums="088292d9caf6059ef328aa7dda332e44 nginx-1.10.1.tar.gz
d0cda555a062e1bc78c5cf646d754be9 ngx-fancyindex-0.4.0.tar.gz
a223ba5180ec796a23686962e5732ff8 headers-more-nginx-module-0.30.tar.gz
9824498b35e879e40d05b9c8348dc4ff lua-nginx-module-0.10.5.tar.gz
+53cccec22ffae9b6f8437f3c198f21f5 nchan-1.0.3.tar.gz
7c1a399d36a75bcfa874d98b5462fc09 nginx-upload-progress-module-0.9.2.tar.gz
320a0229e1553f417c227dd965e1c81b nginx-rtmp-module-1.1.9.tar.gz
256145c0f70d1d1d3b99f854553d48f0 nginx.conf
@@ -245,6 +254,7 @@ sha256sums="1fd35846566485e03c0e318989561c135c598323ff349c503a6c14826487a801 ng
152cc2cf082c23cbc7b0fc76f14af4015d3988783016dc9145edebec17c7e230 ngx-fancyindex-0.4.0.tar.gz
2aad309a9313c21c7c06ee4e71a39c99d4d829e31c8b3e7d76f8c964ea8047f5 headers-more-nginx-module-0.30.tar.gz
4f0292c37ab3d7cb980c994825040be1bda2c769cbd800e79c43eb37458347d4 lua-nginx-module-0.10.5.tar.gz
+24abe863ed1d3bfeb220393a8dc18a6961bab45172ac2a510d3e2e63a2469edb nchan-1.0.3.tar.gz
b286689355442657650421d8e8398bd4abf9dbbaade65947bb0cb74a349cc497 nginx-upload-progress-module-0.9.2.tar.gz
46d914e3ba1f4c2353c1ef01a7423305255cb78226c84fac419586f849b7ea55 nginx-rtmp-module-1.1.9.tar.gz
df873f301f947192c854994bb0e1bac46f73a5d3cf91df997f1b6a8ed26b5724 nginx.conf
@@ -258,6 +268,7 @@ sha512sums="fa1329d40e83340380332dd5e2ed66f08dd59cc7f7582dd0e0193c493353ba550e80
47fd9f405475f96958eb255f9051a9bde1ad8b515356bbaff8f8034ee34ecc17e3574c1d104496c5069c8986e047ca0de386f1b7d2f7317f15be98d69e74b624 ngx-fancyindex-0.4.0.tar.gz
378f2c4b4fbf580e59c8ad3ef5fcb617e4669b7b506a0ae87e4e0bc920d34e16fe55565e48dd57e7b6c37ae8b407646ca64f5d84a2fbbe2d41d719c7643c1a82 headers-more-nginx-module-0.30.tar.gz
a02b8614fdcd063b1087a3114f05402c707343ff3bceabaca1fb98531ba30edea1a525fc45e2f5a49ff155de8d6f9e1155e8870e463476da5703acfd5f8fc3fc lua-nginx-module-0.10.5.tar.gz
+9dd7870815cac2e0c76461b9e425461fb60a861a324eacf6bf59d9bd331704d4d90bf73c5b12cf065a70752179d9bbf2c2b7f68f67c064fe7705edba18bac74f nchan-1.0.3.tar.gz
c31c46344d49704389722325a041b9cd170fa290acefe92cfc572c07f711cd3039de78f28df48ca7dcb79b2e4bbe442580aaaf4d92883fd3a14bf41d66dd9d8c nginx-upload-progress-module-0.9.2.tar.gz
888c268eb0371649e9bf971462e20472f819946f49ef5e50af97d0590a03df6d37c1fa8016eb7ea81faa0c212c429618d399102f513b029c66226d48e444f70c nginx-rtmp-module-1.1.9.tar.gz
ac7e3153ab698b4cde077f0d5d7ac0a58897927eb36cf3b58cb01268ca0296f1d589c0a5b4f889b96b5b4a57bef05b17c59be59a9d7c4d7a3d3be58f101f7f41 nginx.conf