aboutsummaryrefslogtreecommitdiffstats
path: root/main/nmap
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-11 09:19:57 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-18 13:45:50 +0000
commit0bc8d0888c308b0fe86fb873b2dbff99800983e1 (patch)
treea5b5c2b1ca25136c6ca4fade459ab7de2cd14f8f /main/nmap
parent8ba9da3887a3d3030f4c85f2d148279c9bba012a (diff)
downloadaports-0bc8d0888c308b0fe86fb873b2dbff99800983e1.tar.bz2
aports-0bc8d0888c308b0fe86fb873b2dbff99800983e1.tar.xz
main/nmap: build against system pcre, libssh2 and lua5.3
- properly require openssl (status quo, just use a correct parameter) - explicitly require system libpcap (status quo) - explicitly require system libpcre [1] - explicitly require zlib (status quo) - explicitly require system libssh2 [2] - explicitly require system lua5.3 [3] - adjust makedepends accordingly [1] System pcre is newer and properly configured for mips*. [2] This is the ./configure default, just make sure the choice is stable. [3] This is the ./configure default, just let it find the system version. check() passes on x86_64 and mipseln8hf at least, however this commit does not re-enable it due to unclear aarch64 / arm* status.
Diffstat (limited to 'main/nmap')
-rw-r--r--main/nmap/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/nmap/APKBUILD b/main/nmap/APKBUILD
index b2dd5ed2e5..a71a7e0f1a 100644
--- a/main/nmap/APKBUILD
+++ b/main/nmap/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=nmap
pkgver=7.70
-pkgrel=2
+pkgrel=3
pkgdesc="A network exploration tool and security/port scanner"
url="http://nmap.org"
arch="all"
license="custom"
depends=""
-makedepends="libpcap-dev openssl-dev lua-dev linux-headers"
+makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev libssh2-dev lua5.3-dev"
options="!check" #FIXME: fails on armhf and aarch64
subpackages="
$pkgname-doc
@@ -34,11 +34,13 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--without-zenmap \
- --with-liblua=/usr/include \
- --with-openssl=/usr/lib
-
- # fix LUA libs linking order
- make "LUA_LIBS=../liblua/liblua.a -ldl -lm"
+ --with-openssl=yes \
+ --with-libpcap=yes \
+ --with-libpcre=yes \
+ --with-libz=yes \
+ --with-libssh2=yes \
+ --with-liblua=/usr/lua5.3
+ make
}
check() {