aboutsummaryrefslogtreecommitdiffstats
path: root/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-27 13:40:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-27 14:10:23 +0100
commiteabc7596b07258be17d525f0f843f7418878651d (patch)
tree2362cd778e51ff2ac37e9524ac39b22fd86329bd /main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
parent308944d90df71c773c958a1c5ff4ebdb240526a3 (diff)
downloadaports-eabc7596b07258be17d525f0f843f7418878651d.tar.bz2
aports-eabc7596b07258be17d525f0f843f7418878651d.tar.xz
main/nodejs-lts: rename to nodejs
Odd-numbered versions are supported by upstream only for 9 months. Packages in Alpine stable are supported for 2 years, so we should keep only LTS version of Node.js in stable. Therefore the former nodejs package has been renamed to nodejs-current and moved to the community repository, and this one becomes the main nodejs package. See https://github.com/nodejs/LTS#lts-schedule Related to 308944d90df71c773c958a1c5ff4ebdb240526a3
Diffstat (limited to 'main/nodejs/dont-run-gyp-files-for-bundled-deps.patch')
-rw-r--r--main/nodejs/dont-run-gyp-files-for-bundled-deps.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch b/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
new file mode 100644
index 0000000000..d65b456aaf
--- /dev/null
+++ b/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
@@ -0,0 +1,18 @@
+From: Stephen Gallagher <sgallagh@redhat.com>
+Date: Tue, 1 Dec 2015 16:35:29 -0500
+Subject: Disable running gyp files for bundled deps
+
+--- a/Makefile
++++ b/Makefile
+@@ -70,7 +70,7 @@ $(NODE_G_EXE): config.gypi out/Makefile
+ $(MAKE) -C out BUILDTYPE=Debug V=$(V)
+ ln -fs out/Debug/$(NODE_EXE) $@
+
+-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp deps/v8/build/toolchain.gypi deps/v8/build/features.gypi deps/v8/tools/gyp/v8.gyp node.gyp config.gypi
++out/Makefile: common.gypi deps/v8/build/toolchain.gypi deps/v8/build/features.gypi deps/v8/tools/gyp/v8.gyp node.gyp config.gypi
+ $(PYTHON) tools/gyp_node.py -f make
+
+ config.gypi: configure
+--
+2.9.0
+