aboutsummaryrefslogtreecommitdiffstats
path: root/main/nodejs
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-10-24 22:27:08 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2015-10-24 22:27:08 +0000
commit2fc663d50a3ed6b30a36403576432c16d2356961 (patch)
tree8f93f7303ebc1ff0069710941bde2f0832eaacb4 /main/nodejs
parent75612484b69d3575b55a4aec5e8fe4d5bf4d7f63 (diff)
downloadaports-2fc663d50a3ed6b30a36403576432c16d2356961.tar.bz2
aports-2fc663d50a3ed6b30a36403576432c16d2356961.tar.xz
main/nodejs: set FPU for arm
https://wiki.debian.org/ArmHardFloatPort#Minimum_CPU_.26_FPU
Diffstat (limited to 'main/nodejs')
-rw-r--r--main/nodejs/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index e943d6e7da..29c8ebed03 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -1,4 +1,3 @@
-# Contributor: Jose-Luis Rivas <me@ghostbar.co>
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
pkgname=nodejs
@@ -26,9 +25,11 @@ prepare() {
build() {
cd "$_builddir"
+ [ "$CARCH" = "armhf" ] && local _FPU="--with-arm-fpu=vfpv3-d16"
./configure --prefix=/usr \
--shared-zlib \
--shared-libuv \
+ $_FPU \
--shared-openssl || return 1
make || return 1
}