aboutsummaryrefslogtreecommitdiffstats
path: root/main/nodejs
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-31 21:46:17 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-10-31 22:59:33 +0100
commit617771fdbcdadc12574efaf287732d1ee9c9418c (patch)
treef0bc0eab6a3db5fed72b32d0db2527ceba18cc12 /main/nodejs
parent02648bbd2c16e538b6f8044c9779a80d5626c713 (diff)
downloadaports-617771fdbcdadc12574efaf287732d1ee9c9418c.tar.bz2
aports-617771fdbcdadc12574efaf287732d1ee9c9418c.tar.xz
main/nodejs: upgrade to 8.9.0
Closes https://bugs.alpinelinux.org/issues/8008
Diffstat (limited to 'main/nodejs')
-rw-r--r--main/nodejs/APKBUILD15
-rw-r--r--main/nodejs/dont-run-gyp-files-for-bundled-deps.patch23
-rw-r--r--main/nodejs/ppc-fix-musl-mcontext.patch27
3 files changed, 17 insertions, 48 deletions
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index ca7fb8774e..973b0afd4a 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -14,7 +14,7 @@
pkgname=nodejs
# Note: Update only to even-numbered versions (e.g. 6.y.z, 8.y.z)!
# Odd-numbered versions are supported only for 9 months by upstream.
-pkgver=6.11.5
+pkgver=8.9.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - LTS version"
url="http://nodejs.org/"
@@ -29,8 +29,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-npm::noarch"
provides="nodejs-lts=$pkgver" # for backward compatibility
replaces="nodejs-current nodejs-lts" # nodejs-lts for backward compatibility
source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz
- dont-run-gyp-files-for-bundled-deps.patch
- ppc-fix-musl-mcontext.patch"
+ dont-run-gyp-files-for-bundled-deps.patch"
builddir="$srcdir/node-v$pkgver"
prepare() {
@@ -84,12 +83,7 @@ package() {
dev() {
provides="nodejs-lts-dev=$pkgver" # for backward compatibility
-
default_dev
-
- # Remove some junk.
- rm -r "$subpkgdir"/usr/lib/node_modules
- rmdir -p "$subpkgdir"/usr/lib || :
}
npm() {
@@ -104,6 +98,5 @@ npm() {
mv "$pkgdir"/usr/lib/node_modules/npm "$subpkgdir"/usr/lib/node_modules/
}
-sha512sums="63b80b68cda08121993db7c35bb4db4823c4c9c0fc596a20713bea55290bb434b940c42b0f3c7da64283842625870449c602bdafd7ad230de1b54b0280183f37 node-v6.11.5.tar.gz
-a8be538158b7c96341a407acba30450ddc5c3ad764e7efe728d1ceff64efc3067b177855b9ef91b54400be6a02600d83da4c21a07ae9d7dc0774f92b2006ea8b dont-run-gyp-files-for-bundled-deps.patch
-54a96cdc103bdffa9ba5283f59c64a35774e272f3a944d6475e3f669f95f7d75bcca6db3b12b9af76ea463f531763105aeabb302872652ced6a2bcb66f1eace0 ppc-fix-musl-mcontext.patch"
+sha512sums="653de03b94f0a3ce1e62ac707b95165afd2a21af8995842aa6965e8855e5d98718b7fa406c6dff01f03c01c9a6df1005bc0505cc6092a92690663ad44cc36462 node-v8.9.0.tar.gz
+ba95f21b1e80717ef63941854e7ed412f64a91da068c0dbf0d6d9697333ee266c9f4cd7bf1a01111eeb28aa66adefd8a58cfb3e82debb84b43e35e9dc914dd36 dont-run-gyp-files-for-bundled-deps.patch"
diff --git a/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch b/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
index d65b456aaf..ba521dc4fc 100644
--- a/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
+++ b/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
@@ -1,18 +1,21 @@
-From: Stephen Gallagher <sgallagh@redhat.com>
-Date: Tue, 1 Dec 2015 16:35:29 -0500
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sat, 26 Nov 2016 01:32:00 +0200
Subject: Disable running gyp files for bundled deps
+Author: Stephen Gallagher <sgallagh@redhat.com>
+
+Modified 2016-11-26 by Jakub Jirutka <jakub@jirutka.cz> to update for
+Node.js 7.2.0
+
--- a/Makefile
+++ b/Makefile
-@@ -70,7 +70,7 @@ $(NODE_G_EXE): config.gypi out/Makefile
+@@ -72,8 +72,7 @@
$(MAKE) -C out BUILDTYPE=Debug V=$(V)
ln -fs out/Debug/$(NODE_EXE) $@
--out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp deps/v8/build/toolchain.gypi deps/v8/build/features.gypi deps/v8/tools/gyp/v8.gyp node.gyp config.gypi
-+out/Makefile: common.gypi deps/v8/build/toolchain.gypi deps/v8/build/features.gypi deps/v8/tools/gyp/v8.gyp node.gyp config.gypi
+-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
+- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
++out/Makefile: common.gypi deps/v8/gypfiles/toolchain.gypi \
+ deps/v8/gypfiles/features.gypi deps/v8/src/v8.gyp node.gyp \
+ config.gypi
$(PYTHON) tools/gyp_node.py -f make
-
- config.gypi: configure
---
-2.9.0
-
diff --git a/main/nodejs/ppc-fix-musl-mcontext.patch b/main/nodejs/ppc-fix-musl-mcontext.patch
deleted file mode 100644
index 240f0262fc..0000000000
--- a/main/nodejs/ppc-fix-musl-mcontext.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Gustavo Romero <gromero@br.ibm.com>
-Date: Mon, 27 Mar 2017 22:24:16 +0000
-Subject: [PATCH] Fix compilation on PPC when libc musl is used instead of glibc
-
-Musl on Power does not define regs member as a pt_regs pointer type,
-hence it's necessary to use member gp_regs instead.
-
---- a/deps/v8/src/profiler/sampler.cc
-+++ b/deps/v8/src/profiler/sampler.cc
-@@ -487,9 +487,17 @@
- state.sp = reinterpret_cast<Address>(mcontext.gregs[29]);
- state.fp = reinterpret_cast<Address>(mcontext.gregs[30]);
- #elif V8_HOST_ARCH_PPC
-+#if V8_LIBC_GLIBC
- state.pc = reinterpret_cast<Address>(ucontext->uc_mcontext.regs->nip);
- state.sp = reinterpret_cast<Address>(ucontext->uc_mcontext.regs->gpr[PT_R1]);
- state.fp = reinterpret_cast<Address>(ucontext->uc_mcontext.regs->gpr[PT_R31]);
-+#else
-+ // Some C libraries, notably Musl, define the regs member as a void pointer,
-+ // hence we use the gp_regs member instead.
-+ state.pc = reinterpret_cast<Address>(ucontext->uc_mcontext.gp_regs[32]);
-+ state.sp = reinterpret_cast<Address>(ucontext->uc_mcontext.gp_regs[1]);
-+ state.fp = reinterpret_cast<Address>(ucontext->uc_mcontext.gp_regs[31]);
-+#endif
- #elif V8_HOST_ARCH_S390
- #if V8_TARGET_ARCH_32_BIT
- // 31-bit target will have bit 0 (MSB) of the PSW set to denote addressing