aboutsummaryrefslogtreecommitdiffstats
path: root/main/nodejs
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-24 23:19:52 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-24 23:21:15 +0100
commit5f220d12ebabb440dee30ea3787d78835521362d (patch)
treee0853003fe7e2db5603ae2964548a657d85fd688 /main/nodejs
parent474cc4cd5c15580de11a3d0b71bca48f40a2f90b (diff)
downloadaports-5f220d12ebabb440dee30ea3787d78835521362d.tar.bz2
aports-5f220d12ebabb440dee30ea3787d78835521362d.tar.xz
main/nodejs: move npx executable to -npm subpkg
This removes unintentional dependency of nodejs on nodejs-npm. Fixes #8289
Diffstat (limited to 'main/nodejs')
-rw-r--r--main/nodejs/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index fd4efab369..c53e836426 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -18,7 +18,7 @@ pkgname=nodejs
# Note: Update only to even-numbered versions (e.g. 6.y.z, 8.y.z)!
# Odd-numbered versions are supported only for 9 months by upstream.
pkgver=8.9.3
-pkgrel=0
+pkgrel=1
pkgdesc="JavaScript runtime built on V8 engine - LTS version"
url="https://nodejs.org/"
arch="all"
@@ -96,7 +96,7 @@ npm() {
replaces="nodejs-current-npm $pkgname" # $pkgname for backward compatibility
mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/npm "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/usr/bin/np[mx] "$subpkgdir"/usr/bin/
mkdir -p "$subpkgdir"/usr/lib/node_modules
mv "$pkgdir"/usr/lib/node_modules/npm "$subpkgdir"/usr/lib/node_modules/