aboutsummaryrefslogtreecommitdiffstats
path: root/main/nodejs
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-03-03 11:01:14 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-03-03 11:01:14 +0000
commite73dba576b50c952f19c9c6be4c1a3627457f42a (patch)
treec8f728d828806175d23fa2a017fc8e4a6968e4a0 /main/nodejs
parent89e885da4b9186286c75bd9e0e916fce09dbe723 (diff)
downloadaports-e73dba576b50c952f19c9c6be4c1a3627457f42a.tar.bz2
aports-e73dba576b50c952f19c9c6be4c1a3627457f42a.tar.xz
main/nodejs: do not set vfpv3 fpu for armhf
This reverts most of commit 2fc663d5. Debian target armv7+ in their armhf. We target armv6+ which does not support vfpv3. ref #5211
Diffstat (limited to 'main/nodejs')
-rw-r--r--main/nodejs/APKBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index 6945328801..29170a2f9b 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
pkgname=nodejs
pkgver=4.3.1
-pkgrel=0
+pkgrel=1
pkgdesc='Evented I/O for V8 javascript'
url='http://nodejs.org/'
arch='all'
@@ -27,11 +27,9 @@ prepare() {
build() {
cd "$_builddir"
- [ "$CARCH" = "armhf" ] && local _FPU="--with-arm-fpu=vfpv3-d16"
./configure --prefix=/usr \
--shared-zlib \
--shared-libuv \
- $_FPU \
--shared-openssl \
|| return 1
# we need run mksnapshot at build time so paxmark it early