aboutsummaryrefslogtreecommitdiffstats
path: root/main/nrpe/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-08-28 20:54:34 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-08-28 22:04:39 +0200
commit7c0d8c329bd8243b567190add4f3e5e706cf7480 (patch)
tree40be290cff0eb5e85260d2101895f9d853709bb4 /main/nrpe/APKBUILD
parentbe028bccbef2a1e271f99c343b1b24168b297871 (diff)
downloadaports-7c0d8c329bd8243b567190add4f3e5e706cf7480.tar.bz2
aports-7c0d8c329bd8243b567190add4f3e5e706cf7480.tar.xz
main/nrpe: modernize abuild
Diffstat (limited to 'main/nrpe/APKBUILD')
-rw-r--r--main/nrpe/APKBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/main/nrpe/APKBUILD b/main/nrpe/APKBUILD
index 63077d01b8..3b22d088cb 100644
--- a/main/nrpe/APKBUILD
+++ b/main/nrpe/APKBUILD
@@ -8,23 +8,21 @@ pkgdesc="NRPE allows you to remotely execute Nagios plugins on other Linux/Unix
url="http://www.nagios.org/download/addons"
arch="all"
license="GPL"
-depends=""
makedepends="libressl-dev perl"
install="nrpe.pre-install"
subpackages="$pkgname-plugin"
source="http://downloads.sourceforge.net/nagios/$pkgname-$pkgver.tar.gz
nrpe.initd
nrpe.confd"
-
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ default_prepare
+ update_config_sub
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
@@ -34,15 +32,16 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--libexecdir=/usr/lib/nagios/plugins \
- --enable-command-args \
- || return 1
- make || return 1
+ --enable-command-args
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
+
make DESTDIR="$pkgdir" install install-daemon-config
- #remove plugin since its in separate package
+
+ # Remove plugin since its in separate package.
rm -rf "$pkgdir"/usr/lib
install -Dm755 "$srcdir"/nrpe.initd "$pkgdir"/etc/init.d/nrpe
install -Dm644 "$srcdir"/nrpe.confd "$pkgdir"/etc/conf.d/nrpe
@@ -50,16 +49,11 @@ package() {
plugin() {
pkgdesc="Nagios plugin to check result via NRPE daemon"
- cd "$_builddir"
+
+ cd "$builddir"
make DESTDIR="$subpkgdir" install-plugin
}
-md5sums="3921ddc598312983f604541784b35a50 nrpe-2.15.tar.gz
-ca97858cb1995111ebf69b9a2cbb6ccb nrpe.initd
-6bd25a1ace9e108c5014a83adcad15b3 nrpe.confd"
-sha256sums="66383b7d367de25ba031d37762d83e2b55de010c573009c6f58270b137131072 nrpe-2.15.tar.gz
-42d93743669764cc30dca8773578bbdb6bf4376a22c1f654cf76c8e19b8e4df4 nrpe.initd
-c07c0eef454515c622bb0c12846ad73e961193cacd7c46cf70e49e09605e6f08 nrpe.confd"
sha512sums="03ce9774b5112d03235dc9da075770d89d1bcc5ffa5faf221ff7ea8ec5c92ded1e1ae9222581a87cf53736d190ac047e1acce7edc2f31f26c432d786cdef0e73 nrpe-2.15.tar.gz
7e8ed9170b20cc1e33caacc7e007bd4eef17aa100a24802f67d4c06870d3228b68da4661c75dbe0a74711efe0c9155111c380bcd80a352fe0e198aaa6ccbaa2e nrpe.initd
1070f3aaae560c2b2ee5195eb23787504864a8b6e1a92181158269d30e525733136482c7d299a71bbd44f575d2c919935adf9c162be6cd4fa99bbad06b9c3b0c nrpe.confd"