aboutsummaryrefslogtreecommitdiffstats
path: root/main/nspr
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-06-26 09:38:06 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-06-26 06:39:35 +0000
commit4aeb29c2882335cf673498cdfde421e36310a697 (patch)
tree2e011eba3a05574d6a8850ae6eaf6e3d7fd64347 /main/nspr
parentd3b790540a7a423fda9d6833882cf24e2843272f (diff)
downloadaports-4aeb29c2882335cf673498cdfde421e36310a697.tar.bz2
aports-4aeb29c2882335cf673498cdfde421e36310a697.tar.xz
main/nspr: fix musl build to have ipv6 and large-file support
the header file tests these features using __GLIBC__ version, supply musl feature list by hand for now. (cherry picked from commit 525c6ef6561b7edd68f02004716c2a36af03076c)
Diffstat (limited to 'main/nspr')
-rw-r--r--main/nspr/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/nspr/APKBUILD b/main/nspr/APKBUILD
index 531e902820..5a996bc7b0 100644
--- a/main/nspr/APKBUILD
+++ b/main/nspr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nspr
pkgver=4.10.6
-pkgrel=0
+pkgrel=1
pkgdesc="Netscape Portable Runtime"
url="http://www.mozilla.org/projects/nspr/"
arch="all"
@@ -33,12 +33,16 @@ build() {
conf="--enable-64bit"
fi
cd "$_builddir"/build
+ # ./nspr/pr/include/md/_linux.h tests only __GLIBC__ version
+ # to detect c-library features, list musl features here for now.
+ CFLAGS="$CFLAGS -D_PR_POLL_AVAILABLE -D_PR_HAVE_OFF64_T -D_PR_INET6 -D_PR_HAVE_INET_NTOP -D_PR_HAVE_GETHOSTBYNAME2 -D_PR_HAVE_GETADDRINFO -D_PR_INET6_PROBE" \
../nspr/configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--disable-debug \
--enable-optimize \
+ --enable-ipv6 \
$conf \
|| return 1
make CC="${CC:-gcc}" CXX="${CXX:-g++}" || return 1