aboutsummaryrefslogtreecommitdiffstats
path: root/main/nspr
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-11-30 10:36:50 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 10:32:03 +0000
commitd989793e640eaf607c7929d7efbc021e969dab60 (patch)
tree96ded9ed17d50b029e929e0fb33e41016db47da8 /main/nspr
parent3e794c73f0f3a27275077889bdac0106bf107daf (diff)
downloadaports-d989793e640eaf607c7929d7efbc021e969dab60.tar.bz2
aports-d989793e640eaf607c7929d7efbc021e969dab60.tar.xz
main/nspr: fix build on mips* (sgidefs.h)
Use sgidefs.h from linux-headers and replace _ABI64 references with non-GCC counterpart (_ABI64 is only defined with -mabi=64 thus -Wundef errors arise in some dependent projects with -mabi=32).
Diffstat (limited to 'main/nspr')
-rw-r--r--main/nspr/APKBUILD10
-rw-r--r--main/nspr/fix-sgidefs-usage.patch40
2 files changed, 46 insertions, 4 deletions
diff --git a/main/nspr/APKBUILD b/main/nspr/APKBUILD
index aed03922ca..5cee61d0d3 100644
--- a/main/nspr/APKBUILD
+++ b/main/nspr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nspr
pkgver=4.19
-pkgrel=0
+pkgrel=1
pkgdesc="Netscape Portable Runtime"
url="http://www.mozilla.org/projects/nspr/"
arch="all"
@@ -9,11 +9,12 @@ license="MPL-1.1 GPL-2.0 LGPL-2.1"
options="!check" # No test suite.
depends=
# -dev package does not ship any symlinks so dependency cannot be autodetected
-depends_dev="nspr"
-makedepends="autoconf automake"
+depends_dev="nspr linux-headers"
+makedepends="autoconf automake linux-headers"
subpackages="$pkgname-dev"
source="https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v$pkgver/src/nspr-$pkgver.tar.gz
fix-getproto.patch
+ fix-sgidefs-usage.patch
"
prepare() {
@@ -61,4 +62,5 @@ package() {
}
sha512sums="45a48111d0f89db0649a5e1356719868ff81881f9cf48c22c1d13b0831978b103f19e9840d6a5359fcdc90d763c0a60f0a29f7840d756a5efbd53ce1afd36844 nspr-4.19.tar.gz
-ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch"
+ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch
+69e804907d1a8867912511818d9827e4d7fd36ff44253cb21f4a5527610076874ddf5aada87717ef6454162c21248c9f7c3395376c585129134950c12f90ac0f fix-sgidefs-usage.patch"
diff --git a/main/nspr/fix-sgidefs-usage.patch b/main/nspr/fix-sgidefs-usage.patch
new file mode 100644
index 0000000000..3719d6452a
--- /dev/null
+++ b/main/nspr/fix-sgidefs-usage.patch
@@ -0,0 +1,40 @@
+--- a/nspr/pr/include/md/_linux.cfg
++++ b/nspr/pr/include/md/_linux.cfg
+@@ -498,8 +498,8 @@
+
+ #elif defined(__mips__)
+
+-/* For _ABI64 */
+-#include <sgidefs.h>
++/* For _MIPS_SIM_ABI64 */
++#include <asm/sgidefs.h>
+
+ #ifdef __MIPSEB__
+ #define IS_BIG_ENDIAN 1
+@@ -511,7 +511,7 @@
+ #error "Unknown MIPS endianness."
+ #endif
+
+-#if _MIPS_SIM == _ABI64
++#if _MIPS_SIM == _MIPS_SIM_ABI64
+
+ #define IS_64
+
+@@ -555,7 +555,7 @@
+ #define PR_BYTES_PER_WORD_LOG2 3
+ #define PR_BYTES_PER_DWORD_LOG2 3
+
+-#else /* _ABI64 */
++#else /* _MIPS_SIM_ABI64 */
+
+ #define PR_BYTES_PER_BYTE 1
+ #define PR_BYTES_PER_SHORT 2
+@@ -597,7 +597,7 @@
+ #define PR_BYTES_PER_WORD_LOG2 2
+ #define PR_BYTES_PER_DWORD_LOG2 3
+
+-#endif /* _ABI64 */
++#endif /* _MIPS_SIM_ABI64 */
+
+ #elif defined(__arm__)
+