aboutsummaryrefslogtreecommitdiffstats
path: root/main/ntop/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-12 00:17:35 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-12 00:17:35 +0000
commit892c77681639a0e3026cbc1e5a3899b3c204cce0 (patch)
tree2334b9ad29a8870ee79751efb8c8ec4c51048e98 /main/ntop/APKBUILD
parent32557eb83e20f057856eb2c292fb45990f7d11bd (diff)
downloadaports-892c77681639a0e3026cbc1e5a3899b3c204cce0.tar.bz2
aports-892c77681639a0e3026cbc1e5a3899b3c204cce0.tar.xz
main/ntop: build fix aarch64
Diffstat (limited to 'main/ntop/APKBUILD')
-rw-r--r--main/ntop/APKBUILD35
1 files changed, 17 insertions, 18 deletions
diff --git a/main/ntop/APKBUILD b/main/ntop/APKBUILD
index b636001a5e..62558b039a 100644
--- a/main/ntop/APKBUILD
+++ b/main/ntop/APKBUILD
@@ -20,21 +20,15 @@ source="http://sourceforge.net/projects/$pkgname/files/$pkgname/Stable/$pkgname-
automake.patch
ntop.initd
ntop.confd
- ntop-update-geoip-db"
+ ntop-update-geoip-db
+ config.sub
+ config.guess"
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
+ cp $srcdir/config.sub $srcdir/config.guess nDPI || return 1
./autogen.sh --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var/lib \
@@ -45,13 +39,12 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
-
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
install -m755 -D "$srcdir"/ntop-update-geoip-db \
- "$pkgdir"/usr/bin/ntop-update-geoip-db
+ "$pkgdir"/usr/bin/ntop-update-geoip-db
# ntop internal db dir
install -d -o ntop -g ntop -m755 "$pkgdir"/var/lib/ntop
chown -R ntop.ntop "$pkgdir"/usr/share/ntop
@@ -62,16 +55,22 @@ a2729d5c8f132974c2720112364a924e include-sys-types.h.patch
86eeacb33ececc416e66fc4260518f05 automake.patch
af32215f664231f37a9a8147d89d97f0 ntop.initd
1303915a8435560acf27748ea0cea484 ntop.confd
-080de490aeed421775e6f2472d86cb94 ntop-update-geoip-db"
+080de490aeed421775e6f2472d86cb94 ntop-update-geoip-db
+ab5cdf7080934d24cf4ca0739db766a1 config.sub
+52f80eee57d1a5dc581fbb1f1c6a7bad config.guess"
sha256sums="7e8e84cb14d2173beaca4d4cb991a14d84a4bef84ec37b2276bc363f45c52ef8 ntop-5.0.1.tar.gz
2419f7ace6ad93db47a4bccd3e50350f5f837d0b269d4237d6c58d1b28d6b8c8 include-sys-types.h.patch
5e8ddd9d269c4fc23a2376091dcd7a1afedb3d1e15aa4d1ab5d13bb11173f3f7 automake.patch
e1a859b168287950d828ba4d31a9bbeb46e46d1ea3cc1e43f20fa2ef2742d478 ntop.initd
b582253490df4cde55dda97585d45d16b2968296da7e9bc996dde932cf42584d ntop.confd
-3604d0a728b203211fab05eca829a7e93bc05c04f252937ffbf630813420eef6 ntop-update-geoip-db"
+3604d0a728b203211fab05eca829a7e93bc05c04f252937ffbf630813420eef6 ntop-update-geoip-db
+98cc817af4b814522e5d776cd005996efae1198b86f50a8518e6b4fac9f24bb3 config.sub
+3c32dbef4195927bffd562b699095ad3271d9b06f1a3ff08eb313100b579a5fe config.guess"
sha512sums="f52c40e6c00c8d2f46b68078c5f9aef8ed78670f92a0a81f66f2f44c71d41bc4c001b4550f19b71c546f7c07cbbed15e0aa1ee13873ac63a11678bf2b8483f2a ntop-5.0.1.tar.gz
b67705152cd8723ba3e1c340ca55267134dddae04dd281fae262d07ce273a78d24bf40c297fe61ea7f70deb9cb7d59445e8a3ce360ed7810497e63052e1a9214 include-sys-types.h.patch
ce284679f9ecf589139b6cfdba95a76df5205f5292a5ff88b7cdeb39fe01b4fef27fb097a6a594017aa015a2474fea6c5729917423398a911e1732329ec1504a automake.patch
22b61d88e1fc30106d07ee87701ff46b7f63f1ee2aa7bb5666d9cb5cb6251c583f793c80a5d799ac27fcb63650e7ecacb37e7992feb8aa8cbc2d326b36b05a8f ntop.initd
8693050cab03eeb29b59e0a7b173c7791625e8cd6bc33eaa5d74a50ab3ecf435577d7918626cfe3963a0d23d4522a737737b2b9fd8335df29784858a6191813d ntop.confd
-7b5ae8dbd7d5d084c7278af1deb64a903b106663c3195df70acead3e8d7e14fbd996e69d5132c0ddac9147b3e70892c91695d834ab7b22fec2569efcd52df5f6 ntop-update-geoip-db"
+7b5ae8dbd7d5d084c7278af1deb64a903b106663c3195df70acead3e8d7e14fbd996e69d5132c0ddac9147b3e70892c91695d834ab7b22fec2569efcd52df5f6 ntop-update-geoip-db
+fb999aada492f963fdf86184629a7351e5ff3adac6f4707a2d150ae18cea02478b4ebcb1d2d0bd11698ed74415d2a73bc07d8c0d96a5035bd567d2738fa73128 config.sub
+ec32c1c81a460033d1b419292f408974409d08cfc754af92ca5af303cc848fc5dc3a019028c6724346e96ab5d600519862fd9a2c3f01ae6cf7139ff377de4b80 config.guess"