aboutsummaryrefslogtreecommitdiffstats
path: root/main/oidentd
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-15 22:28:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-15 22:32:16 +0200
commit47c81f33217bdd39084e1cfd784642122015a19c (patch)
tree5c375d3ea85b8e02a47b94e2fe9adcfa8675ebe1 /main/oidentd
parentea1688d74a29f37292b237eddeb48928395d3a23 (diff)
downloadaports-47c81f33217bdd39084e1cfd784642122015a19c.tar.bz2
aports-47c81f33217bdd39084e1cfd784642122015a19c.tar.xz
main/oidentd: rewrite init script
Diffstat (limited to 'main/oidentd')
-rw-r--r--main/oidentd/APKBUILD5
-rw-r--r--main/oidentd/oidentd.confd17
-rw-r--r--main/oidentd/oidentd.initd54
3 files changed, 32 insertions, 44 deletions
diff --git a/main/oidentd/APKBUILD b/main/oidentd/APKBUILD
index 0f397b3f8f..594051a023 100644
--- a/main/oidentd/APKBUILD
+++ b/main/oidentd/APKBUILD
@@ -38,6 +38,5 @@ package() {
}
sha512sums="c9ab6819e54ad1b8ff59b72f9aebc300b3a31cf7cfe689ec2f34337bf3e5755a7a67a7724ccf388dd3c7c90330cd955dfc790f61efa716931456c42cff2bcb67 oidentd-2.2.3.tar.bz2
-a05de9b08f87a200309c39d3bc3aba0aa2c6461c3c43a9d851299e6083f0ca9a362409b0db93ca069c7a50d3a14169a308aea51b3d42ebf0180a4b4c99bf5126 oidentd.conf
-c00c246ed223bd56407e10edbc50e247c32b4552c256b344b8497814446f1f7aa0c36daeb6aaf7c29cc9b31aeca992ee3b85fa480ed9380a68cdd8bd1b5f95b9 oidentd.initd
-d3aba90970df7cf9869934380267b3f5c687a86ad532fa854728e2f7506551254ae4bda0a1edece24d26c4da6c29d7e9c44923a29fd67016b88a7766c6e6a050 oidentd.confd"
+b161b75eb315185d836c25e94393c927fc16136519901eaecae62622ea5556fdafc1f8af70457ad1f7890e50d46d3939b8f0dd97050a183b0055d94d78e26f5d oidentd.initd
+41156b9030e1f64e5849dae36bd67f3489a0921a7f3f9fc3cfdecd0e5fbe34b926cd784eaf9e41d7dcdca87ed037834ad1e347f1770f0bcf08b74f4a742341c0 oidentd.confd"
diff --git a/main/oidentd/oidentd.confd b/main/oidentd/oidentd.confd
index 3116889e67..32c9b9bdbd 100644
--- a/main/oidentd/oidentd.confd
+++ b/main/oidentd/oidentd.confd
@@ -1,4 +1,13 @@
-# oidentd start-up options
-USER="nobody"
-GROUP="nobody"
-OPTIONS=""
+# Configuration for /etc/init.d/oidentd
+
+# Path of the configuration file.
+#cfgfile="/etc/oidentd.conf"
+
+# User or UID to run as after dropping privileges.
+#user="nobody"
+
+# Group or GID to run as after dropping privileges.
+#group="nobody"
+
+# Additional options for oidentd.
+#command_args=""
diff --git a/main/oidentd/oidentd.initd b/main/oidentd/oidentd.initd
index bd60872a3a..a1a880ba97 100644
--- a/main/oidentd/oidentd.initd
+++ b/main/oidentd/oidentd.initd
@@ -1,43 +1,23 @@
#!/sbin/openrc-run
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/net-misc/oidentd/files/oidentd-2.0.7-init,v 1.4 2007/10/24 11:38:14 uberlord Exp $
-depend() {
- need net
- after firewall
-}
-
-check_config() {
- if [ -z "${USER}" ]
- then
- eerror "Please set \$USER in /etc/conf.d/oidentd!"
- return 1
- fi
- if [ -z "${GROUP}" ]
- then
- eerror "Please set \$GROUP in /etc/conf.d/oidentd!"
- return 1
- fi
-
- if [ "$(sysctl -n security.bsd.see_other_uids 2>/dev/null)" = "0" ]; then
- eerror "${SVCNAME} cannot work if the sysctl security.bsd.see_other_uids is 0"
- return 1
- fi
-}
+# Upper case variables are for backward compatibility only.
+: ${cfgfile:="/etc/oidentd.conf"}
+: ${user:=${USER:-"nobody"}}
+: ${group:=${GROUP:-"nobody"}}
+command="/usr/sbin/oidentd"
+command_args="
+ --foreground
+ --config $cfgfile
+ --user $user
+ --group $group
+ ${command_args:-$OPTIONS}"
+command_background="yes"
+pidfile="/run/$RC_SVCNAME.pid"
-start() {
- check_config || return 1
- ebegin "Starting oidentd"
- OPTIONS="${OPTIONS} -u ${USER} -g ${GROUP}"
- start-stop-daemon --start --quiet --exec /usr/sbin/oidentd -- $OPTIONS
- eend $?
-}
+required_files="$cfgfile"
-stop() {
- ebegin "Stopping oidentd"
- start-stop-daemon --stop --quiet --exec /usr/sbin/oidentd
- eend $?
+depend() {
+ need net
+ after firewall
}
-