aboutsummaryrefslogtreecommitdiffstats
path: root/main/omxplayer/fix-makefile.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-05-16 07:40:46 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-05-16 07:40:46 +0000
commit83bb4f23dc439c99df6dc39abb8626631f705e48 (patch)
tree87d5a8f62eb4aad08606ee5b19aad1d72be6c519 /main/omxplayer/fix-makefile.patch
parenta224e7438ba752caa259dc3c0bfcb3aa1e38a379 (diff)
downloadaports-83bb4f23dc439c99df6dc39abb8626631f705e48.tar.bz2
aports-83bb4f23dc439c99df6dc39abb8626631f705e48.tar.xz
main/omxplayer: upgrade to 20160513, add dbus fix
Diffstat (limited to 'main/omxplayer/fix-makefile.patch')
-rw-r--r--main/omxplayer/fix-makefile.patch16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/omxplayer/fix-makefile.patch b/main/omxplayer/fix-makefile.patch
index 96d57a2620..d809c1d658 100644
--- a/main/omxplayer/fix-makefile.patch
+++ b/main/omxplayer/fix-makefile.patch
@@ -1,6 +1,6 @@
---- omxplayer-6ee9a0a5488119786990b6f91990d59d6e35427c/Makefile.orig
-+++ omxplayer-6ee9a0a5488119786990b6f91990d59d6e35427c/Makefile
-@@ -48,7 +48,7 @@
+--- omxplayer/Makefile.orig
++++ omxplayer/Makefile
+@@ -48,10 +49,10 @@
omxplayer.o: help.h keys.h
version:
@@ -8,8 +8,12 @@
+ sh gen_version.sh > version.h
omxplayer.bin: version $(OBJS)
- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
-@@ -79,14 +79,12 @@
+- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvchostif -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
++ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+ $(STRIP) omxplayer.bin
+
+ help.h: README.md Makefile
+@@ -79,14 +80,12 @@
make -f Makefile.ffmpeg
make -f Makefile.ffmpeg install
@@ -24,5 +28,5 @@
cp COPYING $(DIST)/usr/share/doc/omxplayer
cp README.md $(DIST)/usr/share/doc/omxplayer/README
cp omxplayer.1 $(DIST)/usr/share/man/man1
-- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
+- cp -P ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
- cd $(DIST); tar -czf ../$(DIST).tgz *