aboutsummaryrefslogtreecommitdiffstats
path: root/main/omxplayer/fix-makefile.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-11-21 13:30:08 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-11-21 13:30:55 +0000
commitd4fc3dd773fcd71d72fd8bc125f336ffc28bb766 (patch)
treea65d9998e1d5cbdd857b6c6eb0a121aaa9551d0c /main/omxplayer/fix-makefile.patch
parentae8891170c0dcb34ffe7830398173a04cfdc1203 (diff)
downloadaports-d4fc3dd773fcd71d72fd8bc125f336ffc28bb766.tar.bz2
aports-d4fc3dd773fcd71d72fd8bc125f336ffc28bb766.tar.xz
main/omxplayer: fix dbus include paths
Diffstat (limited to 'main/omxplayer/fix-makefile.patch')
-rw-r--r--main/omxplayer/fix-makefile.patch9
1 files changed, 6 insertions, 3 deletions
diff --git a/main/omxplayer/fix-makefile.patch b/main/omxplayer/fix-makefile.patch
index 23a206d71f..76f11870ce 100644
--- a/main/omxplayer/fix-makefile.patch
+++ b/main/omxplayer/fix-makefile.patch
@@ -1,16 +1,19 @@
--- omxplayer-2ee17b22a6149a043a2e402580504f282c615373.orig/Makefile
+++ omxplayer-2ee17b22a6149a043a2e402580504f282c615373/Makefile
-@@ -3,7 +3,10 @@
+@@ -3,9 +3,12 @@
LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/
LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lbrcmGLESv2 -lbrcmEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
+LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/
+LIBS+=-lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
-+
- INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -I/usr/include/freetype2 -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
+-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -I/usr/include/freetype2 -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
++INCLUDES+=-I./ -Ilinux $(shell pkg-config --cflags dbus-1 freetype2) -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
++
DIST ?= omxplayer-dist
+ STRIP ?= strip
+
@@ -50,10 +53,10 @@
omxplayer.o: help.h keys.h