aboutsummaryrefslogtreecommitdiffstats
path: root/main/omxplayer/fix-makefile.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-21 09:43:44 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-11-21 09:44:13 +0000
commit6242564feffb32797bff21ecc81df5ade1cf57e7 (patch)
treea4fd54d1dd2572cd708310e635fb9742b18fe95c /main/omxplayer/fix-makefile.patch
parent34c7cd2046c880a8fefddf8077c970975bda9aa3 (diff)
downloadaports-6242564feffb32797bff21ecc81df5ade1cf57e7.tar.bz2
aports-6242564feffb32797bff21ecc81df5ade1cf57e7.tar.xz
main/omxplayer: move from testing, refresh snapshot
Diffstat (limited to 'main/omxplayer/fix-makefile.patch')
-rw-r--r--main/omxplayer/fix-makefile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/main/omxplayer/fix-makefile.patch b/main/omxplayer/fix-makefile.patch
new file mode 100644
index 0000000000..96d57a2620
--- /dev/null
+++ b/main/omxplayer/fix-makefile.patch
@@ -0,0 +1,28 @@
+--- omxplayer-6ee9a0a5488119786990b6f91990d59d6e35427c/Makefile.orig
++++ omxplayer-6ee9a0a5488119786990b6f91990d59d6e35427c/Makefile
+@@ -48,7 +48,7 @@
+ omxplayer.o: help.h keys.h
+
+ version:
+- bash gen_version.sh > version.h
++ sh gen_version.sh > version.h
+
+ omxplayer.bin: version $(OBJS)
+ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+@@ -79,14 +79,12 @@
+ make -f Makefile.ffmpeg
+ make -f Makefile.ffmpeg install
+
+-dist: omxplayer.bin omxplayer.1
++install: omxplayer.bin omxplayer.1
+ mkdir -p $(DIST)/usr/lib/omxplayer
+ mkdir -p $(DIST)/usr/bin
+ mkdir -p $(DIST)/usr/share/doc/omxplayer
+ mkdir -p $(DIST)/usr/share/man/man1
+- cp omxplayer omxplayer.bin $(DIST)/usr/bin
++ cp omxplayer.bin $(DIST)/usr/bin/omxplayer
+ cp COPYING $(DIST)/usr/share/doc/omxplayer
+ cp README.md $(DIST)/usr/share/doc/omxplayer/README
+ cp omxplayer.1 $(DIST)/usr/share/man/man1
+- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
+- cd $(DIST); tar -czf ../$(DIST).tgz *