aboutsummaryrefslogtreecommitdiffstats
path: root/main/omxplayer/fix-makefile.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-11-21 08:18:03 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-11-21 12:44:42 +0000
commitae8891170c0dcb34ffe7830398173a04cfdc1203 (patch)
tree9aeb1c7649ac956ac2046fe72a228e017d9cc931 /main/omxplayer/fix-makefile.patch
parent23af91024d6898a78dae14c1c46ba85e96092611 (diff)
downloadaports-ae8891170c0dcb34ffe7830398173a04cfdc1203.tar.bz2
aports-ae8891170c0dcb34ffe7830398173a04cfdc1203.tar.xz
main/omxplayer: upgrade to snapshot of 2016-10-17
Diffstat (limited to 'main/omxplayer/fix-makefile.patch')
-rw-r--r--main/omxplayer/fix-makefile.patch24
1 files changed, 13 insertions, 11 deletions
diff --git a/main/omxplayer/fix-makefile.patch b/main/omxplayer/fix-makefile.patch
index 80aa0e6205..23a206d71f 100644
--- a/main/omxplayer/fix-makefile.patch
+++ b/main/omxplayer/fix-makefile.patch
@@ -1,18 +1,17 @@
-diff --git a/Makefile b/Makefile
-index 2857e94..a889fca 100644
---- a/Makefile
-+++ b/Makefile
-@@ -2,7 +2,8 @@ include Makefile.include
+--- omxplayer-2ee17b22a6149a043a2e402580504f282c615373.orig/Makefile
++++ omxplayer-2ee17b22a6149a043a2e402580504f282c615373/Makefile
+@@ -3,7 +3,10 @@
- CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
-
--LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
+ LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/
+ LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lbrcmGLESv2 -lbrcmEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
+LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/
+LIBS+=-lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
- INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
++
+ INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -I/usr/include/freetype2 -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
-@@ -49,10 +50,10 @@ all: dist
+ DIST ?= omxplayer-dist
+@@ -50,10 +53,10 @@
omxplayer.o: help.h keys.h
version:
@@ -25,7 +24,7 @@ index 2857e94..a889fca 100644
$(STRIP) omxplayer.bin
help.h: README.md Makefile
-@@ -80,14 +81,12 @@ ffmpeg:
+@@ -81,17 +84,15 @@
make -f Makefile.ffmpeg
make -f Makefile.ffmpeg install
@@ -42,3 +41,6 @@ index 2857e94..a889fca 100644
cp omxplayer.1 $(DIST)/usr/share/man/man1
- cp -P ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
- cd $(DIST); tar -czf ../$(DIST).tgz *
+
+ install:
+ cp -r $(DIST)/* /