aboutsummaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools/struct_timespec.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-07-24 09:46:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-24 13:59:52 +0000
commit06f984daee0981ccfce8ae0a8b8b663a1c6667f1 (patch)
tree645e47ae4aa142c8c3d25954c4b3982dbfd639b7 /main/open-vm-tools/struct_timespec.patch
parentc9f2cd8c8ebf69fd3447aa4ecff56f2c04799ced (diff)
downloadaports-06f984daee0981ccfce8ae0a8b8b663a1c6667f1.tar.bz2
aports-06f984daee0981ccfce8ae0a8b8b663a1c6667f1.tar.xz
main/open-vm-tools: upgrade to 9.4.6 and fix build with musl
Diffstat (limited to 'main/open-vm-tools/struct_timespec.patch')
-rw-r--r--main/open-vm-tools/struct_timespec.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/main/open-vm-tools/struct_timespec.patch b/main/open-vm-tools/struct_timespec.patch
new file mode 100644
index 0000000000..a2c536794a
--- /dev/null
+++ b/main/open-vm-tools/struct_timespec.patch
@@ -0,0 +1,27 @@
+--- open-vm-tools-9.4.6-1770165.orig/configure.ac
++++ open-vm-tools-9.4.6-1770165/configure.ac
+@@ -837,6 +837,7 @@
+ AC_TYPE_PID_T
+ AC_TYPE_SIZE_T
+ AC_CHECK_MEMBERS([struct stat.st_rdev])
++AC_CHECK_MEMBERS([struct timespec.tv_sec],[],[],[[#include <time.h>]])
+ AC_HEADER_TIME
+ AC_STRUCT_TM
+ AC_C_VOLATILE
+--- open-vm-tools-9.4.6-1770165.orig/lib/include/hgfsUtil.h
++++ open-vm-tools-9.4.6-1770165/lib/include/hgfsUtil.h
+@@ -53,13 +53,7 @@
+ # include <time.h>
+ # endif
+ # include "vm_basic_types.h"
+-# if !defined _STRUCT_TIMESPEC && \
+- !defined _TIMESPEC_DECLARED && \
+- !defined __timespec_defined && \
+- !defined sun && \
+- !defined __FreeBSD__ && \
+- !__APPLE__ && \
+- !defined _WIN32
++# if !defined HAVE_STRUCT_TIMESPEC_TV_SEC
+ struct timespec {
+ time_t tv_sec;
+ long tv_nsec;