aboutsummaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2018-11-23 07:42:29 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-27 09:40:59 +0100
commit0bc295a94385b6c443ba52e5af2a1a5d40b6807a (patch)
tree0921994b25ac6e9541a1c2fb5be0f16c0a29caf1 /main/open-vm-tools
parent4d8dff89b31c71af244645024aa9ee5887337e66 (diff)
downloadaports-0bc295a94385b6c443ba52e5af2a1a5d40b6807a.tar.bz2
aports-0bc295a94385b6c443ba52e5af2a1a5d40b6807a.tar.xz
main/open-vm-tools: fix reboot and halt
(cherry picked from commit 00fc18aa0c07998215c7fc55185c63ae496592eb)
Diffstat (limited to 'main/open-vm-tools')
-rw-r--r--main/open-vm-tools/APKBUILD4
-rw-r--r--main/open-vm-tools/systemLinux.c-fixup-for-Alpine.patch36
2 files changed, 39 insertions, 1 deletions
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
index ab9801643c..e2118a9302 100644
--- a/main/open-vm-tools/APKBUILD
+++ b/main/open-vm-tools/APKBUILD
@@ -3,7 +3,7 @@ pkgname=open-vm-tools
pkgver=10.1.15
_pkgsubver=${pkgver#*_p}
_ver=${pkgver/_p/-}
-pkgrel=2
+pkgrel=3
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="https://github.com/vmware/open-vm-tools/"
arch="x86 x86_64"
@@ -32,6 +32,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/vmware/$pkgname/archive/stab
0013-use-off64_t-instead-of-loff_t.patch
0014-remove-references-to-missing-common-agent-etc-config.patch
strerror_r.patch
+ systemLinux.c-fixup-for-Alpine.patch
$pkgname.initd
$pkgname.confd
@@ -125,6 +126,7 @@ d0551458fa6a9d9fd3e576f856fb0269e1a40930ab625bd5243a256a90ca89b3a90e7bd97678ca83
af109a9aab9da5f312e1f06a4db318f577a5bbb22a8974892a9a1f6941865fea663694362dd8ffb0d8cbe776f3297458bec1004131b3e92b8da003506087df39 0013-use-off64_t-instead-of-loff_t.patch
d30c74e2de1ae729fb0eec9f510c89b9c5180478b3ace625dd7a0b3fa3fd269ddbdcf802c6c014e39da794b36891beed2f5b85e7c6a0179ec0723ee6be390782 0014-remove-references-to-missing-common-agent-etc-config.patch
5507a58198179805e4c924b6bd6ac8b026bd602c9e5e4c52213dadf6c8880a23a16ee49a4dfe2db27515c2a36009e609dd81b7ee0d560bbea1ddf6a5324eb7ac strerror_r.patch
+c18280eb3fdfe1e3ecc5aa116369908c71917bd4dd49743a9abf78e0096e8d6c7d4323057cf506ef31886b893b2e4c4839656172edd5097a347efa96aea1c86c systemLinux.c-fixup-for-Alpine.patch
d4d0c0c3042eef4d241c933de6f7c398a88275744b3576efc2f909acd681752f548e4ae4a17eca7db731ee0b9254b46169a48463d12a72ec6354065d788159f4 open-vm-tools.initd
ffc9c945a41e48791bab61ba72fed96c1a6ae3722caa715424e3077d167421b4e2f53bb4d415ab227d1f6e40d6ca3779df41e6b0a38db34b520979fa2b19298d open-vm-tools.confd
5626c68b8ee01ece804f314b829476280e892581a448c27092e32a60b04d40ecfa8e8eca464c4376c3cfc497eb60406798b7383d1a747a173d3cd8b78d23100b open-vm-tools.logrotate"
diff --git a/main/open-vm-tools/systemLinux.c-fixup-for-Alpine.patch b/main/open-vm-tools/systemLinux.c-fixup-for-Alpine.patch
new file mode 100644
index 0000000000..1b7799ec62
--- /dev/null
+++ b/main/open-vm-tools/systemLinux.c-fixup-for-Alpine.patch
@@ -0,0 +1,36 @@
+From db3546f6234506d51caf91e3763bfdf000828156 Mon Sep 17 00:00:00 2001
+From: Henrik Riomar <henrik.riomar@gmail.com>
+Date: Fri, 23 Nov 2018 07:40:22 +0100
+Subject: [PATCH] systemLinux.c: fixup for Alpine
+
+/sbin/shutdown -r now -> /sbin/reboot
+/sbin/shutdown -h now -> /sbin/halt
+---
+ open-vm-tools/lib/system/systemLinux.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/open-vm-tools/lib/system/systemLinux.c b/open-vm-tools/lib/system/systemLinux.c
+index c74d4890..c98ce962 100644
+--- a/open-vm-tools/lib/system/systemLinux.c
++++ b/open-vm-tools/lib/system/systemLinux.c
+@@ -312,7 +312,7 @@ System_Shutdown(Bool reboot) // IN: "reboot or shutdown" flag
+ #elif defined(USERWORLD)
+ cmd = "/bin/reboot";
+ #else
+- cmd = "/sbin/shutdown -r now";
++ cmd = "/sbin/reboot";
+ #endif
+ } else {
+ #if __FreeBSD__
+@@ -322,7 +322,7 @@ System_Shutdown(Bool reboot) // IN: "reboot or shutdown" flag
+ #elif defined(USERWORLD)
+ cmd = "/bin/halt";
+ #else
+- cmd = "/sbin/shutdown -h now";
++ cmd = "/sbin/halt";
+ #endif
+ }
+ if (system(cmd) == -1) {
+--
+2.19.1
+