aboutsummaryrefslogtreecommitdiffstats
path: root/main/openjdk6/icedtea-jdk-iconv-uclibc.patch
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-28 19:52:39 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-28 19:52:39 -0500
commit44c939369e9f5d2aae6463e2cde329f76ffbf427 (patch)
treecf20ed16a2b255eaab158ecf625d205e6680194c /main/openjdk6/icedtea-jdk-iconv-uclibc.patch
parenta1e9d96005522a2efc85ab7d70bf0089d965a145 (diff)
downloadaports-44c939369e9f5d2aae6463e2cde329f76ffbf427.tar.bz2
aports-44c939369e9f5d2aae6463e2cde329f76ffbf427.tar.xz
testing/openjdk6: promote to main
Diffstat (limited to 'main/openjdk6/icedtea-jdk-iconv-uclibc.patch')
-rw-r--r--main/openjdk6/icedtea-jdk-iconv-uclibc.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/openjdk6/icedtea-jdk-iconv-uclibc.patch b/main/openjdk6/icedtea-jdk-iconv-uclibc.patch
new file mode 100644
index 0000000000..68f858167f
--- /dev/null
+++ b/main/openjdk6/icedtea-jdk-iconv-uclibc.patch
@@ -0,0 +1,39 @@
+Index: openjdk/jdk/make/java/npt/Makefile
+===================================================================
+--- openjdk/jdk/make/java/npt/Makefile 2010-06-13 15:11:02.598512448 +0200
++++ openjdk/jdk/make/java/npt/Makefile 2010-06-13 15:11:28.504759286 +0200
+@@ -65,6 +65,8 @@
+ # We don't want to link against -ljava
+ JAVALIB=
+
++LDLIBS += -liconv
++
+ # Add -export options to explicitly spell exported symbols
+ ifeq ($(PLATFORM), windows)
+ OTHER_LCF += -export:nptInitialize -export:nptTerminate
+Index: icedtea6-1.8/openjdk-ecj/jdk/make/java/instrument/Makefile
+===================================================================
+--- openjdk/jdk/make/java/instrument/Makefile 2010-06-13 15:12:14.688505195 +0200
++++ openjdk/jdk/make/java/instrument/Makefile 2010-06-13 15:12:32.641425670 +0200
+@@ -123,6 +123,8 @@
+ # We don't want to link against -ljava
+ JAVALIB=
+
++LDLIBS += -liconv
++
+ #
+ # Add to ambient vpath so we pick up the library files
+ #
+Index: openjdk/jdk/make/sun/splashscreen/Makefile
+===================================================================
+--- openjdk/jdk/make/sun/splashscreen/Makefile 2010-06-13 15:12:48.951840824 +0200
++++ openjdk/jdk/make/sun/splashscreen/Makefile 2010-06-13 15:13:01.191422891 +0200
+@@ -55,6 +55,8 @@
+
+ JAVALIB=
+
++LDLIBS += -liconv
++
+ #
+ # C Flags
+ #