aboutsummaryrefslogtreecommitdiffstats
path: root/main/openrc
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-08-17 20:34:29 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-08-19 13:08:10 +0200
commit4b38f2cbe9a14da6f20ab60bcbe9a8a205b99810 (patch)
treedf62f58a908fb8fe6640905c143dda0cef686c0b /main/openrc
parentbc485e997121472faa7f744699fe89e1eba44105 (diff)
downloadaports-4b38f2cbe9a14da6f20ab60bcbe9a8a205b99810.tar.bz2
aports-4b38f2cbe9a14da6f20ab60bcbe9a8a205b99810.tar.xz
main/openrc: use cp to copy current font to RC_LIBEXECDIR
Diffstat (limited to 'main/openrc')
-rw-r--r--main/openrc/0008-make-consolefont-service-compatible-with-busyboxs-se.patch26
-rw-r--r--main/openrc/APKBUILD8
2 files changed, 16 insertions, 18 deletions
diff --git a/main/openrc/0008-make-consolefont-service-compatible-with-busyboxs-se.patch b/main/openrc/0008-make-consolefont-service-compatible-with-busyboxs-se.patch
index 414e366db5..fa0755bc5c 100644
--- a/main/openrc/0008-make-consolefont-service-compatible-with-busyboxs-se.patch
+++ b/main/openrc/0008-make-consolefont-service-compatible-with-busyboxs-se.patch
@@ -1,4 +1,4 @@
-From 94e322563e1571bce4dda3d49b00732765282851 Mon Sep 17 00:00:00 2001
+From bf1d47b86ae3a4142825de6e79ddd7b933b468c4 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
Date: Wed, 17 Aug 2016 17:52:58 +0200
Subject: [PATCH 8/8] make consolefont service compatible with busyboxs setfont
@@ -7,8 +7,8 @@ Subject: [PATCH 8/8] make consolefont service compatible with busyboxs setfont
Compared to kdbs setfont program it doesn't support -O and -m.
---
conf.d/consolefont | 11 ++---------
- init.d/consolefont.in | 10 ----------
- 2 files changed, 2 insertions(+), 19 deletions(-)
+ init.d/consolefont.in | 7 ++-----
+ 2 files changed, 4 insertions(+), 14 deletions(-)
diff --git a/conf.d/consolefont b/conf.d/consolefont
index e01ae84..75544b2 100644
@@ -34,7 +34,7 @@ index e01ae84..75544b2 100644
-#unicodemap="iso01"
+#consoletranslation="8859-1_to_uni.trans"
diff --git a/init.d/consolefont.in b/init.d/consolefont.in
-index 9fe95af..90fcab6 100644
+index 9fe95af..fce1a70 100644
--- a/init.d/consolefont.in
+++ b/init.d/consolefont.in
@@ -22,7 +22,6 @@ start()
@@ -55,18 +55,16 @@ index 9fe95af..90fcab6 100644
# Set the console font
ebegin "Setting console font [$consolefont]"
-@@ -60,11 +56,5 @@ start()
- done
- eend $retval
-
-- # Store the font so we can use it ASAP on boot
-- if [ $retval -eq 0 ] && checkpath -W "$RC_LIBEXECDIR"; then
-- mkdir -p "$RC_LIBEXECDIR"/console
+@@ -63,7 +59,8 @@ start()
+ # Store the font so we can use it ASAP on boot
+ if [ $retval -eq 0 ] && checkpath -W "$RC_LIBEXECDIR"; then
+ mkdir -p "$RC_LIBEXECDIR"/console
- setfont -O "$RC_LIBEXECDIR"/console/font
-- fi
--
++ cp "/usr/share/consolefonts/$consolefont" \
++ "$RC_LIBEXECDIR"/console/font
+ fi
+
return $retval
- }
--
2.9.3
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index e2d6f579d9..a3ccb3c4df 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -2,7 +2,7 @@
pkgname=openrc
pkgver=0.21.3
_ver=${pkgver/_git*/}
-pkgrel=3
+pkgrel=4
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://git.overlays.gentoo.org/gitweb/?p=proj/openrc.git"
arch="all"
@@ -79,7 +79,7 @@ ac16fca77d315dd92ef39db43dd2b39c 0001-call-sbin-mkmntdirs-in-localmount-OpenRC-
2ba09bebca524be06bd2ba9eeabd1be6 0005-hide-error-when-migrating-var-run-to-run.patch
f402d67b185803ea899053c3bccfc87c 0006-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
63a6b0e12a5c71d66c1dcb64bc907b6d 0007-mount-efivars-read-only.patch
-2a566b361407529cbedee4a1b351268a 0008-make-consolefont-service-compatible-with-busyboxs-se.patch
+18f1bfe026f52d4beeb6823ae6b3db56 0008-make-consolefont-service-compatible-with-busyboxs-se.patch
d83df5513f08f09fa9e7353327701bf7 openrc.logrotate
60b4cf93ca19aff577fd743ab42878a8 hostname.initd
887eba592d487d6ffe2b42cfcd2813df hwdrivers.initd
@@ -97,7 +97,7 @@ d6418b65b9f2f8f31f7b87fb5a3d38baf836b4eed6544f2a6a2b980fd6cc30dd 0003-sysctl.Li
47188ade6627eeadcd9934976f131b7dea574192219be895a9802f6c24d56e09 0005-hide-error-when-migrating-var-run-to-run.patch
0447481a30d1af83293861cf53eef9b0b241d02eeb015e2d10b310acea126c9b 0006-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
cd35c4040a9b21da394c598a8996390dab1c520e93e84707014094ab82827163 0007-mount-efivars-read-only.patch
-c9fefcc93af8d71e6357ba79f42f0e90585b28af6bc9f6d79365cf65995d4510 0008-make-consolefont-service-compatible-with-busyboxs-se.patch
+30320d6cbac7cb4b9baabc0d9196a894393035a8137d4ff55e246f50ec83f120 0008-make-consolefont-service-compatible-with-busyboxs-se.patch
30a81fb2f761083088d4d6a3d435fc842966d44588e9837b45ffd03e48be6eb6 openrc.logrotate
dda515d7d906cebcf4137746939f3fdccc7f504fe097ef1dbf429e3e6773a013 hostname.initd
6cb4d9ea3ad562bcf2697f61f5a76a10481d23f5dead570f82eff576eaca5236 hwdrivers.initd
@@ -115,7 +115,7 @@ e68933f16a2112fdf41bf9827266dd776801656a656fb961c17bb5eaf483e4791e46594b6b47b221
c70d0bb6c8149c370231ef875d37fcfc77a3a6b0511252161abd9c5141bd14d2e12ae74f208f9b8e26057579cb732dad71ce7c1731d79273634d4d69f412565f 0005-hide-error-when-migrating-var-run-to-run.patch
769712a6ad7d401a03b15a29dbe5cb62e67e289a5ff252b470b43a265c7cd51a8bb4819d645c29eb10abdf39d9f705173d1b53d23608f638be7917a6d83a7fc7 0006-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
e1d23634e7b6d68c488efefa5a4c5b1ca59385eaab298bd3ac88903f60dd5b20d634da4c837c5a2fed012ec8b07894547984c0646aef7a3b2ab41250e778a874 0007-mount-efivars-read-only.patch
-7bc9158e5a4ee085551dd15778f5af50323cea5cc8a704c76c1cd78667d4e490a41d3cc4d9778bbb5e11fbd495e8bba7c32356a8140affb983c637d064433ca1 0008-make-consolefont-service-compatible-with-busyboxs-se.patch
+a8651aec74cdea9fbd93f502e530c83d8575f28bfa74a51de4a878e62d67642150dd93b85787b18c70d02b83f27f4575550912e0381b59a68222b6667bb60a42 0008-make-consolefont-service-compatible-with-busyboxs-se.patch
12bb6354e808fbf47bbab963de55ee7901738b4a912659982c57ef2777fff9a670e867fcb8ec316a76b151032c92dc89a950d7d1d835ef53f753a8f3b41d2cec openrc.logrotate
99b542c0903ad6874b8c308b2e0660a4fe2ff9db962dfec65325cd12c368873a2ae800d5e6d42dc4deff775e1d5c0068869eb72581f7ab16e88d5738afe1d3dd hostname.initd
b51d95df7b692aaea3e14ed009d99b46b82500d505e2eeecb6a20136cee140aea4a7377a65ccc5c51fff64be7a50666be48616d179888eaeff9d35178a7a772b hwdrivers.initd