aboutsummaryrefslogtreecommitdiffstats
path: root/main/openrc
diff options
context:
space:
mode:
authorChloe Kudryavtsev <toast@toastin.space>2019-06-09 23:38:11 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-10 08:36:25 +0000
commit6fc2696f3e040530200912be58829329d7b05b27 (patch)
tree5268a2718594842283ef0f35ec5c7e8dbc50ca0e /main/openrc
parentb176c32266a17aa4ea1c9f1929339d2e882c29f3 (diff)
downloadaports-6fc2696f3e040530200912be58829329d7b05b27.tar.bz2
aports-6fc2696f3e040530200912be58829329d7b05b27.tar.xz
main/openrc: Fix respawn_max=0
This is an off-by-one error fixed in April. Latest release is in February. Ths adds a patch for the interim with a note on when to remove it.
Diffstat (limited to 'main/openrc')
-rw-r--r--main/openrc/0010-Allow-0-respawn-max.patch32
-rw-r--r--main/openrc/APKBUILD4
2 files changed, 35 insertions, 1 deletions
diff --git a/main/openrc/0010-Allow-0-respawn-max.patch b/main/openrc/0010-Allow-0-respawn-max.patch
new file mode 100644
index 0000000000..6316c50da4
--- /dev/null
+++ b/main/openrc/0010-Allow-0-respawn-max.patch
@@ -0,0 +1,32 @@
+Source: gentoo: William Hubbs <w.d.hubbs@gmail.com>
+Remove When: OpenRC >0.41.2 is released
+
+OpenRC docs contradict each other on the default values for respawn_max.
+The real value is 10.
+If infinite spawning is desired, it should be set
+to 0.
+However, setting it to 0 is impossible in 0.41.2.
+This upstream patch fixes that.
+
+From 54780a45826f789f1291742eb2c99be369bfe64c Mon Sep 17 00:00:00 2001
+From: William Hubbs <w.d.hubbs@gmail.com>
+Date: Fri, 29 Mar 2019 14:09:08 -0500
+Subject: [PATCH] supervise-daemon: allow --respawn-max to be zero
+
+---
+ src/rc/supervise-daemon.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/rc/supervise-daemon.c b/src/rc/supervise-daemon.c
+index aaa39397..b754a42b 100644
+--- a/src/rc/supervise-daemon.c
++++ b/src/rc/supervise-daemon.c
+@@ -835,7 +835,7 @@ int main(int argc, char **argv)
+
+ case 'm': /* --respawn-max count */
+ n = sscanf(optarg, "%d", &respawn_max);
+- if (n != 1 || respawn_max < 1)
++ if (n != 1 || respawn_max < 0)
+ eerrorx("Invalid respawn-max value '%s'", optarg);
+ break;
+
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index 8a1fa3c059..d647c6eb4e 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -2,7 +2,7 @@
pkgname=openrc
pkgver=0.41.2
_ver=${pkgver/_git*/}
-pkgrel=0
+pkgrel=1
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="https://github.com/OpenRC/openrc"
arch="all"
@@ -23,6 +23,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/OpenRC/openrc/archive/$pkgve
0001-fsck-don-t-add-C0-to-busybox-fsck.patch
0008-fix-undeclared-UT_LINESIZE.patch
0009-Support-early-loading-of-keymap-if-kdb-is-installed.patch
+ 0010-Allow-0-respawn-max.patch
openrc.logrotate
hostname.initd
@@ -123,6 +124,7 @@ d54630d40a2d6b10a325cb012d4efcda997a60c008ca953ce5d60059d3f267308a59dabddf93a5fc
dbe3f170440f0f357f31ac4d49c56a9a7ec22172df2701bf4a0afdee22aedda1f88b9fa5ffdbe19a5eea3c764ad0e4c802e19b95b7082a72d423d46d30c18edd 0001-fsck-don-t-add-C0-to-busybox-fsck.patch
d2b8700f56b05579926352855de8fcee5cf78f0c13200643a5195f8c60e2b5082d476b42cc77b13246b9fb883aa002d723237b0fc7ae84ccd7ebe3b25690cf50 0008-fix-undeclared-UT_LINESIZE.patch
667085d89e194f7e2255d5c098c3d8de272f54cb925710cb98d5e7a6b58982d0acfe15f97b574cfc646b139cd7aa5b527ba700ef9b8048a6d6d9dee8cc74913c 0009-Support-early-loading-of-keymap-if-kdb-is-installed.patch
+275d3e65fa84aaf06f908bf5c99c8e1243acb691fc931b28b2276b586b55b6198986ed9080c28fb2b598b7bdb2d577439031bea6d232eac0d8f9d8f5cb373fa3 0010-Allow-0-respawn-max.patch
12bb6354e808fbf47bbab963de55ee7901738b4a912659982c57ef2777fff9a670e867fcb8ec316a76b151032c92dc89a950d7d1d835ef53f753a8f3b41d2cec openrc.logrotate
259552165ee5e9ca973bbe18d1d9ec5cc67526cb26a9e0ac717076ef4913bb7ff4055d6ccb9f77996ed9c00b67f46edba552e1a21b836068a112dda2428502b3 hostname.initd
c06eac7264f6cc6888563feeae5ca745aae538323077903de1b19102e4f16baa34c18b8c27af5dd5423e7670834e2261e9aa55f2b1ec8d8fdc2be105fe894d55 hwdrivers.initd